--auth-password is not supported

Screenshot attached.

And as a note, I have created a new cloud back up, ensuring that I pic One Drive V2 and not Business, and I get the same warning.

By the way, I don’t know if Duplicati wrote their own forum interface, or if using a third party product, but it is probably the best forum interface I have seen. :smile:

2 Likes

I figured it out! You might want to add this to your KB, or manual or something. It seems that if you use Google Password Manager to save your login password for Duplicati, it will automatically enter it in the auth-password field (even though that field doesn’t exist on the screen).

I looked at the command line again, and realized that the password that it was displaying was my Duplicati password…so I cleared the password manager, and created a new cloud backup job, and now it works!

Thanks for your help.

7 Likes

Just in case, like me, you are looking here because you have warnings like:

The supplied option --auth-username is not supported and will be ignored
The supplied option --auth-password is not supported and will be ignored

Initially I configured my backup job to use OneDrive for Business, but then could not do any operations afterwards due to limits for OneDrive for Business. I reconfigured the job to use OneDrivev2 which fixed my issues, but then got the errors above.

This happens, as @ts678 suggests above, because “changing types can leave leftovers…”. To clean things up, edit the configuration of the job then choose your previous type (in my case OneDrive for Business), remove the data (username and password) then switch back to your new type before clicking Next through the screens then click Save. If you check the Commandline before and after you should see the extraneous options disappear.

5 Likes

It is called “Discourse” and just works beautifully:

1 Like

I solved it using the GUI interface. Had that error on all backups, although the job was done with success.

Go to the job configuration, second step “Destination”. I am using OneDriveV2 as a backup destination.

There you have the three dots menu.

Just use “Copy destination URL to clipboard”, edit it to remove the &auth-password=XXXX, copy it and use the “Import destination URL” to paste it.

It beats having to delete the job and rebuild it…

ABS

9 Likes

That’s frickin’ excellent. Thanks for posting this - it solved the same issue for me just now.

3 Likes

It’s possibly a two-step process, which Firefox “Autofill logins and Passwords” can also do damage on.

  1. Password saver may autofill too many places, getting --auth-password is not supported #4102 (anybody out there expert on unconfusing several overly-eager-to-autofill password managers?)

  2. Changing backend type leaves invalid backend options #3082
    (which could happen without step 1, and whose fix would prevent step 1 from getting into step 2)

1 Like

I was in the same situation, had a previous One DriveBusiness destination configured and supplied options where kept when I changed to OneDrive v2. Jaytee solution solved my issue

1 Like

it worked for me too!
thanks dude!

Fiermont’s solution works perfectly! Thanks!

This absolutely works! I added localhost to LastPass URL rules including host and port matching to prevent the error in the future. Seems like the assumption being made by Duplicati warrants a bug report?

1 Like

I am not even sure which “auto-fill” breaks it (LastPass or Chrome, on my case), but I really struggled to restore a backup because of it last month. I just found out (thanks quinting and Fiermont !) that it also breaks the creation of backups and finally solved the dreaded 2 warnings at the end of some of mine!

I’m using Google Drive, but the solution is the same is the one proposed by Fiermont: Nov '19. You just edit the destination URL, on second step “Destination” of the GUI, removing everything after the authid=[key] (i.e., after the huge string after authid=, starting with the &auth-username=).

Every successful backup, for quite some time until today, would end with 2 warnings:

  • 2020-08-27 15:30:10 -03 - [Warning-Duplicati.Library.Main.Controller-UnsupportedOption]: The supplied option --auth-username is not supported and will be ignored

  • 2020-08-27 15:30:10 -03 - [Warning-Duplicati.Library.Main.Controller-UnsupportedOption]: The supplied option --auth-password is not supported and will be ignored

    And now I was finally able to solve it, without the need to recreate the jobs (and lose all blocks already at the destination).

1 Like

Can you clarify that? I see a non-break warning about an ignored option, with possible explanation here.

I created an account in the forum just to say you nailed it. Kudos!

1 Like

Thank you so much for reasserting what quinting and Fiermont has explained. I actually shifted my duplicati backup from icedrive to google drive. These two errors were pop up when I run the backup to google drive.

I was looking for the auth password to remove as explained but was difficult finding where in the destination screen. I was checking in the advanced option three dots and was overlooking on the top three dots.

So i finally found here in the screenshot Screenshot by Lightshot. First i copied the URL which came after pressing the 3 dots and then importing but removing &user… password until end.
Screenshot by Lightshot

The error goes off. Thank you everyone for the help.

Friend, thanks for sharing your knowledge.
It worked for me too. Thanks

1 Like

This was the solution for me as well, although Firefox password manager. Once removed from there, the backup again worked well. THANKS, I never would have figured that out!

Excellent, this allowed me to get rid of the warning messages as well. Thanks for sharing.

1 Like