Attempted to change block size

I’m getting this error on one of my machines:

You have attempted to change the block-size on an existing backup, which is not supported. Please configure a new clean backup if you want to change the block-size.

I have not changed the block size. I’ve double checked and it is still set to the default of 100kb. I’ve tried adding it as an advanced option set to 100kb, no change.

How can I convince duplicati that the block size is the same as it always has been?

If you Export the job “As Command-line” what value (if any) do you see for the --blocksize= parameter?

Thanks for the quick reply.

I had both --blocksize=100kb and no --blocksize parameter. Same error in both cases. I’ve never had a block size set.

@Pectojin, do you know of a non-sql way to check a backup’s block size?

download a dblock file, unencrypt it, unzip it, check the block sizes :slight_smile:

If the settings claim --blocksize=100kb the database probably does too.

Hmm… That would indeed work, though technically I think it’s possible to have a block SMALLER than the set parameter size. :slight_smile:

I feel the “attempted to change the block size” message should include what blocksize the backup is using. That way if a user has lost their config on a custom blocksize job they’ll know what to use.

@chmac, the only thing I can think of is to do what Pectojin suggested or run a SQL select on the .sqlite database to see what Duplicati THINKS is the block size.

Other than that it’s possible the database got corrupted somehow. :frowning:

Thanks for all the support, I really appreciate it.

I opened the sqlite file for that backup.

SELECT * FROM Configuration;

Interestingly, today I got a different error. Perhaps the blocksize was corrupted somehow and since my experimenting it’s somehow been set back to 100kb. No idea how it happened or what fixed it, but fingers crossed the issue has been resolved. I’ll assume my backup will run successfully tonight, but will post again if not.

Thanks again for the help.

Good plan, though I should point out that the block size check doesn’t (just?) use configuration - it actually scans the block sizes in the database.

So if one of them has gone wonky you might still get the message…