Asus RT-AC68U router(as AP/FTP server) dosent let Duplicati in?

Iam trying to setup backup for my new W10 system on my routers USB port as it in difrent power circuit +makeing backup on same location as the backed up file dosent make it backup in my maind its just wasted space!

Anyway im close to get RPi4s out and builded to get better server houst. But still wanted to get your maind on the problem im having.

I have asus Router(RT-AC68U with newest soft/firmware) set up as AP and new clean USB drive on its USB3 port.
It did show as Samba and connecting it from my PC isnt problem.
But Samba didnt show on Duplicati’s list of adress to copy the backup file so i tryed to set it up as FTP- server.
But even if i give access to that drive for everyone and i can access it witout PW with my brouser just entering, i still get “error 530” on testing access to it on setting up Backup location with Duplicati wizard…

Main Q: I think its still problem on my ASUS side of the backup system? but what do you think?

Picture of Duplicati error(sorry tryed to set it in English, but it didnt get it fully)

Picture of my Router settings that seams to work if you dont ask it from Duplicati…

Any Help is Great! Sorry my English! Cheers Mummy!

I don’t have your router, so I can’t test scenarios.

However, have you tried creating a username/password on the router that is given explicit ftp access (would also need to make sure home directory is set to / or create one for the user)? It may be that the combination of duplicati and the Asus anonymous ftp authentication aren’t getting along.

Good luck!

TL;DR Suggestion sounds good to me, but in case it doesn’t work or you want more, here’s some more…

Thanks to @sylerner for starting. To go deeper, anonymous FTP means you don’t say who you really are, but you might still need to say some placeholder. Sometimes the username is “anonymous” and the server will suggest what it would like for the password. Friendly GUI likely ignores all that, and a web browser likely sends a placeholder password such as “guest”. RFC 1635 is an old 1994 Informational document on FTP.

FTP Commands for Windows is how you can look into whether or not your router will request dummy info, and whether or not it will insist on you typing something in. I mention this mainly if you want to know details or just in case Duplicati intends to do anonymous FTP better in spite of the fact that it’s bad in many ways.

Your SMB omission might be a similar problem of age. Routers often support really old insecure versions which recent Windows versions by default don’t have enabled, especially if that Windows is a new install.

SMBv1 is not installed by default in Windows 10 Fall Creators Update and Windows Server, version 1709 and later versions

[Network Place (Samba) Share] How to access the files on Network Devices using SMBv1 in Windows 10 ?

[Wireless][USB Application] How to set up Media Services and Servers- Network Place (Samba) Share/ Cloud Disk?