Docker backup, restore, repair missing log warnings and emails

I’m getting warnings on restore/repair attempts, but nothing shows in the logs.

If I click “Show” I get nothing, unless I do an actual “Repair” where I see the repair completed with no errors or warnings.

This is the Docker version. No emails are being generated for backups which are working from what I can see, and restores actually complete with no errors - but I can’t see the actual Warning content?

Welcome to the forum @ptruman

I split your post into a new topic because it wasn’t clear it was a new bug in, and discussing every support request on the release note topic is way too unreadable. If it’s a bug, a note can be added.

Was all previously working? If so, on what release? Is the Docker from duplicati, linuxserver, or elewhere?

What does “restore/repair” mean? They are separate operations.

Please clarify “get nothing” and “nothing shows”. Is there a log for that use? Also check About → Show log -->Stored, although usually what goes there is errors on backups. Other operations are better at making a log file in the per-backup logs. That doesn’t mean all detail you’d want is there though. Which case is this?

Job logs typically show a condensed warning format with the first line. It’s a nice summary, but lacks detail.
About → Show log --Live --Warning (or a log file) can catch detail, but you might have to click on some line.

You might also have had a problem after the backup itself. For example, a problem in sending a report of a successful backup is not an unsuccessful backup (so log will be fine), but it might make you a GUI popup.


I run duplicati/duplicati:latest - and updated 25 days ago to the new version. I can’t recall the prior release number but it was still a beta :slight_smile: (maybe ?)

Everything was working fine on the prior version, and I’m seeing zero errors in the backup logs - and typically leave it be, although today I wanted to check a new backup set was working…

When I click “Restore Files” (from within a backup set) OR “Restore” and then choose a backup set, it’s fine until it starts to pull back backup sets and starts showing warnings…but does then show the set of backups. But if I expand a folder, another warning. And so on.

I ran repair on one backup set to see if it would help - it showed warnings but completed with no errors.

I cannot see any warnings in the live logs (with warnings selected).

The only log I DO get is the successful backup or restore completion, showing no warnings. No actual warnings seem visible. Clicking “Show” when the warning appears, just takes me to the backup set log showing all green.

If I follow, you get warnings on the way to or on the page with version selector dropdown, and again after selecting a version and browsing through its files? A typical warning is a yellow box near bottom of page.

Hmm. I would have thought that would be a comprehensive log, although it sometimes seems unreliable.
You could raise its level to Retry, or Verbose, or beyond to see if you can get yours to swing into action…

log-file=<path> plus log-file-log-level is another way to get job logs. Hardest to set up are server log files.
FWIW profiling log level makes a huge log, but also shows the full conversation with your email provider.

All green, but also all previous runs? If so, check About → Show log → Stored to see if anything got there.
The “Show” button seems to always go to the job logs, but that’s not where the logs always actually go…

Ah, I’ve found it.

It appears (bizarrely) to now be showing Verbose errors (it wasn’t before), and I’m seeing SMTP auth errors. I’ve reset the credentials involved and I’m now getting no warnings on operations.

I suspect you can close/delete this one (and thanks for assisting) :slight_smile:

1 Like