, macOS 10.14.2 Duplicati.Library.Modules.Builtin.CheckMonoSSL-MissingCerts

Even after adding the certs I still get the Duplicati.Library.Modules.Builtin.CheckMonoSSL-MissingCerts warning.

Downloaded the certs:

curl -O https://curl.haxx.se/ca/cacert.pem

Added the certs (128 added) to the root as well as me:

sudo cert-sync --user cacert.pem
cert-sync --user cacert.pem

ps aux revealed the Duplicati and mono processes are run as root.

Any other way to resolve this?

Fiddled around a bit more.

sudo cert-sync --user cacert.pem

Don’t know where these certs go. If you do, let us know!
But this does not work correctly on systems without the root account enabled.

First do

sudo su


certmgr -list -c Trust

came up empty


cert-sync --user cacert.pem

All certs are now correctly listed with

certmgr -list -c Trust

These certs are in:


Then the warning disappears.

1 Like

Great step-by-step solution. Thanks for that! I’ll be marking it as Solved, if you have any other problems please let me know to undo this action