ystem.Threading.Tasks.TaskCanceledException: Uma tarefa foi cancelada

I always get this error message. I checked the files and were successfully sent to the destination (Onedrive).

2019-05-23 17:04:40 -03 - [Error-Duplicati.Library.Main.Operation.TestHandler-FailedToProcessFile]: Failed to process file duplicati-b9fd128a0797b4a2f881ab988b2e32d09.dblock.zip
System.Threading.Tasks.TaskCanceledException: Uma tarefa foi cancelada.
em Duplicati.Library.Main.BackendManager.GetForTesting(String remotename, Int64 size, String hash)
em Duplicati.Library.Main.Operation.TestHandler.DoRun(Int64 samples, LocalTestDatabase db, BackendManager backend)

Hello @teconsult and welcome to the forum!

Do you know whether you have set a larger remote volume size (–dblock-size) than the default 50 MB?

Sometimes OneDrive users set that quite large to avoid a possible limit of 5000 files in a backup folder.

Do you know (for example from an speed test) what your maximum upload and download speeds are?

Errors similar to this can occur if a dblock download doesn’t finish fast enough (probably 100 seconds).

Adding Advanced option –http-operation-timeout set to a larger number of seconds might stop the error.

Set remote volume to 500mb, Upload to 400kbps, and total initial backup size is 100Gb

If that’s –throttle-upload, can you try removing it? I’m developing a suspicion it makes “Hash mismatch” in OneDrive which would be in the details of “Failed to process file” that are harder to find. You can look over your backup logs more closely, or perhaps watch the server log (About --> Show log --> Live) at Warning.

For a 500 MB dblock in 100 seconds, you need downloads to run at least 40 Mbit/sec or this may happen.
Did --http-operation-timeout help? I’m not sure how uploads are working either, especially at 400 Kbit/sec.

Throw TimeoutException upon HTTP timeout #3778 is a recent change to improve timeout handling, but it would be a better plan to adjust timeouts to be long enough that they don’t happen for the typical transfers.