Windows 10 tray icon always red/failed

I’ve had a failed backup two days ago, and since this time the tray icon of duplicati on Windows 10 is always displayed in red, even though 2 or 3 successfully backups have been performed since that time:

What do I have to do to get back the green icon?

Best regards,

How is Duplicati installed - as a service or just the tray icon?

To be clear, it sounds like the backups AND the web interface appear to be working correctly, just the icon shows a red X?

My GUESS is that the tray icon is unable to connect to the backend that actually does the backups. So the tray icon complains with a red X but the “service” happily does backups.

This sounds like the “new install error” that @kenkendk has noted elsewhere. In my experience it will persist in a new install until an actual error occurs and is cleared via the “dismiss” button. The easiest way to do this is run a backup and then abort in the middle of the job. When it completes the next time, the error state will go away.


OK - my guess was totally wrong. The red X does indeed indicate an error has been logged.

Normally when you log into the GUI you get a message at the bottom of the screen about the log and upon clearing the message the icon should return to normal.

So in this instance the issue appears to be that the error message either never showed or was somehow closed without acknowledgement, thus leaving the icon in the red-x / error state.

I have a similar issue on one of my Linux text VMs where the error logged seems to have potentially been about about updating the web UI itself. And indeed closing and re-opening the tray icon does not change it’s state:

Killing the service and restarting the tray icon (in other words using the tray icon webhost instead of the service one) did not resolve the issue. In fact, it logged some more of the same kinds of errors.

@dominicdesu, are you seeing any errors in your “Show log” page like mine above?

Reference to the original issue I found:!topic/duplicati/-QeuRgjSJLY

FWIW I was referring to the issue mentioned here - at least to me it sounds exactly like what’s being described here (if it’s a new install anyway, which I guess i’m not sure about).

yes, it is a new install. I was using Duplicati 1 before and installed Duplicati 2 two days ago. I didn’t install duplicati explicitly as a service, I just kept the “Launch Duplicti at startup” option enabled in the installer.

The web interface and backups are working fine. It’s just that the icon is misleading because the backups actually work fine.
And yes, there is an error in the log (Sept. 24th), because I provided incorrect sftp information when I first set up the backup. However, since fixing the sftp data, the backup ran successfully two or three times.

I can confirm that the red tray icon disappears if I start and cacnel a backup job, and then click dismiss on the error message in the web interface. Haven’t seen this message when the sftp login failed…

Thanks for the workaround :slight_smile:!


It sounds like your start/cancel suggestion worked for dominicdesu so that’s great!

FYI - it also fixed my issue. I kept thinking it wasn’t a new install without realziaing this was the VM I used to test the how-to steps for the Ubunut service install, so who knows what all I did to this por machine. :slight_smile:

1 Like

Just checked the log file, thought it was only about the failed login, but actually I get the same error as you:

24. Sept. 2017 13:49: Request for http://localhost:8200/api/v1/remoteoperation/test gave error
System.Net.Sockets.SocketException (0x80004005): Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte
   bei Renci.SshNet.Abstractions.SocketAbstraction.Connect(IPEndPoint remoteEndpoint, TimeSpan connectTimeout)
   bei Renci.SshNet.Session.SocketConnect(String host, Int32 port)
   bei Renci.SshNet.Session.Connect()
   bei Renci.SshNet.BaseClient.Connect()
   bei Duplicati.Library.Backend.SSHv2.CreateConnection()
   bei Duplicati.Library.Backend.SSHv2.List()
   bei Duplicati.Server.WebServer.RESTMethods.RemoteOperation.TestConnection(String url, RequestInfo info)
   bei Duplicati.Server.WebServer.RESTHandler.DoProcess(RequestInfo info, String method, String module, String key)
24. Sept. 2017 13:49: Reporting error gave error
System.ObjectDisposedException: In einen geschlossenen TextWriter kann nicht geschrieben werden.
   bei System.IO.__Error.WriterClosed()
   bei System.IO.StreamWriter.Flush(Boolean flushStream, Boolean flushEncoder)
   bei Duplicati.Server.WebServer.RESTHandler.DoProcess(RequestInfo info, String method, String module, String key)

Thanks for the followup! Hopefully this will help somebody narrow down the specifics of this hopefully infrequent but annoying scenario. :slight_smile: