When starting Duplicati, I get Index Out of Bounds

When starting up in Edge, I get an error indicating index is outside the bounds of the array. I’m using Duplicati 2.0* on Windows 10


If I try to hit the page in Firefox, I don’t get that error, but I get no configurations. I see this in the console:


May be related - when I try to create or edit a configuration, I get nothing in the dropdown for Storage Type. I am not able to create or save any configuration. But the existing ones still run.

Hi @swingbeat, welcome to the forum!

A lot of changes have happened in the Duplicati 2 line, can you tell what specific version of Duplicati you’re using?

This sounds a lot like the side effects of not refreshing the page after getting a “Missing XSRF” error in the browser. Do you recall seeing any of those messages?

Hi, I have the latest duplicati 2.0 beta version. I don’t remember the number but I checked on the day I posted. Let me know if you need the real version number (can only get it when I get home).

I have seen missing xsrf. Sometimes I get that and sometimes I get the invalid index error. I am sure I have tried refreshing he page when that happens but let me know if there is something else I can do. I will explicitly try refreshing when I get home :slight_smile:

Ok, I’m home now. Here is the number at the top of the Changelog:
2017-08-01 -

I also tried refreshing the page, I still get “Index was outside the bounds of the array”.

I get the same error… but I’ve been running this software for over a month.

I had been getting the Missing XSRF error, and had been hitting refresh and it was working fine…

Now all I get is the “Index was outside the bounds of the array” error. If I edit or create a new job the destination drop down menu is empty.


Just upgraded to new release… v2.0.3.3 - came out this morning. Problem solved

Great! I was about to suggest that as I was pretty sure most of those issues were resolved since Hopefully an upgrade to the new beta will work for @swingbeat as well!

Upgrading fixed the problem. Thanks!!


I’ve just installed 2018-04-02 - and I’m now getting the index out of bounds error (Chrome). It did work when I installed it about an hour ago (well it didn’t open with this error anyway) but then I unsuccessfully started a new backup (Add New Backup). I didn’t finish the backup detail forms as i couldn’t find or didn’t know how to enter the path of the drive I was after (NAS drive). Could the failed attempt have broken it?
Refreshing the browser just brings the error msgbox up again.

Rebooting the computer seems to have fixed the error. I’ve also managed to create a successful backup job.

An oldie, but a good. :smiley:

Glad you were able to get around the issue, though it would be nice if it didn’t happen in the first place.

Do you recall if it was the Destination or the Source that you didn’t complete if you filled out anything else before hitting Save on step 5 (options)? (Hopefully we can recreate the issue to better target a fix.)

An oldie, but a good. :smiley:

ha ha! Yes. Then reinstall Windows, etc…

It was the first step in the process - Destination.
All the dialog boxes were loaded but I couldn’t work out how to specify my NAS drive so I didn’t finish. I’m pretty sure I wouldn’t have clicked on save (but who knows…).
After reading some other help stuff I found that I could map the NAS drive to a letter so I came back to try again.
That’s when I got the error.

Windows 10.

I’m still running Duplicati 1.3.4 on my main computer and it seems to work great (only tested restore a couple of times and never for a whole backup set though).
Does Duplicati still offer the non-web browser version?

If by that you mean version 1.x, then - well - yes, you can still download and use it. However, it’s not support or being updated anymore so we really don’t recommend it.

That’s odd because I can’t figure out how to get a job to “save” WITHOUT getting to step 5 (Options) and clicking the “Save” button. Of course I’m still testing in (not the version you have) so that could be the reason…

JonMikelV, you may have misread what I wrote. I wrote “I’m pretty sure I wouldn’t have clicked on Save”
I probably just closed the browser tab. It was only after rebooting that I got to save the backup job.

I will persevere with the 2. versions as I’m sure they will be good - just a hiccup on first try but all good now.

That’s good.

Hopefully my not being able to recreate it means it’s either been fixed or is hard to make happen so hopefully nobody else will bump into it.

I’ve flagged your “I rebooted” post as the “solution” - please let me know if you disagree.