Webgui fails to load after trying to add SSL cert

Hello as the title indicates I was trying to setup the webgui to work with HTTPS. I ran the following command in the linux shell and now the webgui refuses to load.

sudo duplicati-server --webservice-interface=any --webservice-sslcertificatefile=/usr/lib/duplicati/cert/certificate.pfx --webservice-sslcertificatepassword=MyPassword

I tried un-installing and re-installing duplicati, but it still fails to load. Some sort of backups are still running, but I am not sure that they are working correctly as I can see evidence of large backups, even when the source files haven’t changed. Any help would be appreciated, in getting the gui working again without a total OS re-install.

Getting HTTPS to work properly would be icing on the cake, but at this point I would settle to have the gui working again.

I looked into this further, and I was able to restore my WebGui access by removing the package, performing an apt clean, and reinstalling. I would still like to figure out how to setup the gui with a ssl cert so any help with that would be appreciated.

Through further testing I discovered that, when the main duplicati service was disabled using systemctl, that the following command started the server with https

/usr/bin/mono-sgen /usr/share/Duplicati/updates/ --webservice-port=8300 --webservice-interface= --webservice-sslcertificatefile=/usr/lib/duplicati/cert/certificate.pfx --webservice-sslcertificatepassword=MyPassword --log-file=/var/log/duplicati.log --log-level=Profiling

I tried editing the existing service to start with these variables, and while the service would start, I couldn’t access the gui, much like my original issue. So I ended up following the instructions on the following page to create a service for duplicati using the above command and now everything seems to be running fine.

I’m glad you found a solution. Would you mind creating a #howto post with the instructions? Or at least marking your reply as Solution?

I could probably put together a how to in the coming days. I can’t seem to figure out how to mark this as resolved at least I don’t see it on my mobile.