[Warning-Duplicati.Library.Main.Operation.BackupHandler-SnapshotFailed]: Fallo al crear una instantánea: Intento de realizar una operación no válida

Hello again,

I am receiving a Warning message everytime I make a Backup Job in this machine running Windows 10. I have triend copying de Alpha files as stated in this forum, plus install and reinstall de VC_redist.x64 from Microsoft and still get the warning in the very last moment of the Job.

I am attaching the Log messages, Hope you can give some tips in solving this.

Thanks and Hoipe you and family enjoy a Happy X-Mas



Log data:
2021-12-20 17:27:01 -03 - [Warning-Duplicati.Library.Main.Operation.BackupHandler-SnapshotFailed]: Fallo al crear una instantánea: Intento de realizar una operación no válida.
System.UnauthorizedAccessException: Intento de realizar una operación no válida.
en Alphaleonis.Win32.Vss.VssBackupComponents…ctor()
en Alphaleonis.Win32.Vss.VssImplementation.CreateVssBackupComponents()
en Duplicati.Library.Common.IO.VssBackupComponentsHelper.GetVssBackupComponents()
en Duplicati.Library.Snapshots.WindowsSnapshot…ctor(IEnumerable1 sources, IDictionary2 options)
en Duplicati.Library.Snapshots.SnapshotUtility.CreateWindowsSnapshot(IEnumerable1 folders, Dictionary2 options)
en Duplicati.Library.Main.Operation.BackupHandler.GetSnapshot(String sources, Options options)

Are you using the --snapshot-policy option and if so are you running Duplicati with elevation?

Hello JimboJones,

Thanks for your reply, I do have the snapshot policy option enabled and I have Duplicati running as a Service however can you explain how can I run it with elevation?

Thanks and Very Best Regards,


This post does a decent job of explaining how to move to a service based install.

Hope that helps, if you have any issues let me know.

Hello JimboJones,

Finally I solved it, I figured out that if the backup sends a Warning at the end, y set the snapshot configuration to Auto and it worked.

Just wondering why this System Works this way.

Thanks a lot for the Support given and enjoy the holidays,

Take care,

Sebastian Miranda

From the manual

“Setting this to auto makes Duplicati attempt to create a snapshot, and fail silently if that was not allowed or supported.”

Did you try doing a restore? Chances are you still have the same errror.

To confirm, you ran Duplicati.WindowsService.exe to make a Windows service (a very specific thing)?

Unless you used option below, it should be running as SYSTEM, which should not be having this issue.

Supported options for the install command:

  • /localuser
    Installs the service as a local user.

Please check About → System info to check the UserName value. Is it your user or the SYSTEM user?

snapshot-policy talks about why you might want snapshots, and the privilege level Windows demands, however it would be nice to hear from you why you’re trying to use them. I’m not sure you have them…

At code level, you might just be converting the Warning you used to have into an Information message.

You can look at About → Show log → Live → Information to see if you still have the failure (now hidden).
Whether or not this affects the restore depends on what your reason was for trying to get snapshots on.

Hello ts678,

I checked the About → System Info → UserName Value and it appears as the actual local user

The way the Windows Service is installed is Duplicati.WindowsService.exe install --webservice-interface=any --webservice-port=8200

Due to the pandemic issues most systems are accessed remotely so the user simply connects and disconnects leaving apps up and running. This leaves Oulook open and other Office documents locked. Duplicati is able to save files that are locked that is why we have the snapshot policy enabled.

I changed the setting to Auto and received a Success result instead of Warning of the backup and I was able to perform a partial restore as a test with some warnings but could open the trial file.

Thanks so much for your Support,


Running as a regular user is why Duplicati’s snapshot’s aren’t working. Windows won’t do them unless the user has Administrator privileges in effect, which for normal users may mean responding to a UAC prompt.

The question is whether you are connecting to it. It should not be the actual local user, but the system user.

Simply having Duplicati start either manually or automatically at sign-in will start Duplicati with the Tray Icon feature which runs a built-in Duplicati server which searches for an open port. If 8200 is taken, it uses 8300.

Is the user specifically asking for port 8200? If they just let their personal Duplicati open, it might be at 8300, however if that’s so, they can change the address in the browser to 8200 to see if there’s another Duplicati.

This was commented on earlier as merely suppressing the Warning. Both the manual and code were cited. You would have to look at the mentioned Information level log for the hidden failure at the start of the backup.

Does the same file restore differently if backed up when getting a Warning? If so, I don’t know why that’s so, however you would have to check your log to see if your change is (as suspected) just hiding the message.

If it turns out you’re not backing up locked files as well as you like, the cure is to add the –no-hosted-server option to the Duplicati.GUI.TrayIcon.exe startup shortcut. This will have it use Windows service’s port 8200, however there might be nothing there currently so some things would have to be migrated from user profile.