# Very large backup to B2 failing with "GetResponse Timed Out"

**URL:** https://forum.duplicati.com/t/very-large-backup-to-b2-failing-with-getresponse-timed-out/1223
**Category:** Support
**Created:** [October 31, 2017, 3:15am UTC](https://forum.duplicati.com/t/very-large-backup-to-b2-failing-with-getresponse-timed-out/1223 "2017-10-31T03:15:34Z")
**Posts on this page:** 1
**Showing post:** 3

<div class="post-metadata">

### Author: ![kenkendk](https://forum.duplicati.com/user_avatar/forum.duplicati.com/kenkendk/32/5305_2.png) [@kenkendk](https://forum.duplicati.com/u/kenkendk)
#### Post date: [October 31, 2017, 8:13am UTC](https://forum.duplicati.com/t/very-large-backup-to-b2-failing-with-getresponse-timed-out/1223/3 "2017-10-31T08:13:44Z")

</div>

> [@sonbal](#):
>
> Each attempted backup now runs for almost exactly 10 minutes

It sounds like you are hitting the response timeout of 10 minutes when fetching the list of remote files.

In the canary builds I have added a new option that can change the timeout value: `--http-operation-timeout=20m`.

I have also added the option `--b2-page-size=100` that allows you to change the number of files returned in each request.

> [@sonbal](#):
>
> Would I be better off breaking my backup into a handful of smaller (say 500 GB) backups? Would increasing my block size help? Any other suggestions?

I think this usually helps to have smaller independent backups, as there is less overhead when something needs to be fixed.

But I think the problem here is the number of remote volumes. You can try to change the volume size to something like 200MB, which will reduce the number of remote files.

---

_[View the full topic](https://forum.duplicati.com/t/very-large-backup-to-b2-failing-with-getresponse-timed-out/1223)._
