Update attempt trashed installation; please help me recover

New user here. Six weeks ago, I installed Duplicati across multiple OS computers in my household and since then I have been successfully creating back-ups to a Fedora microserver on my home network. So far I have really liked the software!

Win10 PC
Duplicati installed as a service; also running tray icon with --no-hosted-server option so I can connect to the service

I recently received a notification that the software update was available. When I clicked on the install button, it did not successfully update. After rebooting, it seems to have trashed my Duplicati installation on my Win10 machine as I no longer can connect to the Duplicati service through the web GUI (localhost:8200/ngax/index.html) as I get an error “This site can’t be reached. localhost refused to connect….”. The tray icon also no longer appears and is also missing from my start-up folder.

Running services.msc shows me that Duplicati is still running as a service even though I can’t connect to this service with the web GUI!

If I manually try to start up the tray with the --no-hosted-server option, nothing happens (no idea if or where any errors would be logged). If I start up the tray without the --no-hosted-server option, the Duplicati tray starts up but now have two instances of Duplicati running. I can right click the tray to open the web GUI for the second Duplicati process but now all my backup configuration information is missing as presumably this is associated with the Duplicati process running as a service.

I would be very grateful if I could get some assistance on troubleshooting to 1) recover my installation and subsequently 2) fix the updating problems. If need be, I would be quite happy to reinstall the software but I don’t want to loose my backup configuration information since it took several days to create the intitial backups.


Probably your backups and backup configurations are ok.
All settings and backup configurations are stored in %appdata%\Duplicati, %localappdata%\Duplicati or Data, located in the Duplicati program folder.
In one of these folders, you will find a file named Duplicati-server.sqlite and probably one or more .sqlite files with random-character filenames.

These steps will probably fix your problems:

  • Close the Duplicati tray icon.
  • Stop the Duplicati 2 service
  • Check in the Task Manager if there are any active Duplicati processes. Kill all processes that are related to Duplicati.
  • Download the Zip version from the download page.
  • Extract the Zip archive and copy the contents over the existing installation (probably in C:\Program Files\Duplicati 2).
  • Start the Duplicati service
  • Start the Tray icon

Could you describe what it did? For my own service install, update Install is usually OK. Activate has a known issue (which has so far resisted repair) which activates the old version (workaround is simply service restart).

What version does it show in About --> System Info? You’ll see BaseVersionName and ServerVersionName. The reason there are two versions is because the base looks around for any installed update it should run.
Downgrading / reverting to a lower version describes the plan. If you find your failed update folder (it should be named looking emptier than the Program Files base version, that would keep it from being used.

I’d agree that Duplicati running as a service keeps its configuration in a different place by default, although the plan is actually the same. What changes is the user, which is SYSTEM by default, so Duplicati is under C:\Windows\System32\config\systemprofile. After Duplicati gets back up, it would be best to use the Export GUI option to save any configurations you want to be sure are preserved. They’re not automatically saved, and Windows has a bad habit of cleaning out the SYSTEM profile during its twice-a-year version updates…

Hi @gstreet, welcome to the forum!

@ts678’s plan is a good one, but I have a few questions.

What version were you one before the update (I’m curious ifba downgrade is an option)?

Are you able to run the service from the command line? That may provide done detail on what’s happening.

Did you try the Duplicati URL with and without https and on other ports such as 8300?

Thank you; I do have various *.sqlite files in my c:\Program Files\Duplicati 2\data directory so I hopefully still have the backup config info.

@ts678 and @JonMikelV : to answer your questions,

What Version am I running

  • ServerVersion :
  • ServerVersionName : -
  • ServerVersionType : Beta
  • BaseVersionName :

I was trying to update to version per the update notification I received in the web GUI

Could you describe what it did?

I clicked on the Install button in the Update notification I received in the web GUI. It downloaded a file and then I got an error saying that it could not activate as I had backups running. I waited until my backups were complete and I clicked on the update button again. The file downloaded again and then nothing happened. I decided to reboot my PC and then I was unable to connect back to my configuration files.

Did you try the Duplicati URL with and without https and on other ports such as 8300?

Yes, other ports do no not work. Original installation was on port 8200

These steps will probably fix your problems:

@kees-z, I’ll try your recommended steps and report back.

edit: fixed after posting prematurely

Thanks everyone! @kees-z suggested fix worked perfectly. Once I reinstalled the software from the zip file, I can reconnect to my configuration files and I am now running the new version

One last question: I ran a quick incremental backup to make sure everything was working correctly and I got a red error message saying

Unexpected difference in fileset version 6: 2/11/2018 2:20:25 PM (database id: 2), found 39 entries, but expected 41

I’m unclear what is causing this and how to fix it. It doesn’t appear that I am getting a detailed error log to go with this. I would appreciate a little more help!


That seems to be the error du jour - this post seemed to help for another user:

For extreme error logging, you can set –log-file-log-level=Profiling and specify a –log-file, but the log is huge. Even with that, this check is basically a comparison between a tiny SQL query and an enormous one on files. With such a small number, you could probably even go to “Restore from” and form your own opinion, or even perhaps compare it to backups from around the same time (if you have any, and if your file count was stable).

I’m starting to wonder if got better at discovering this issue in older backups. There was another here, along with directions on how to “fix” it by deleting the confused version. Hopefully neighboring ones are good. Deleting a version just means you lose that specific view. Some people routinely set up retention rules to trim versions out of their backups as they grow older. Even after deduplication, this can save some backup space.

Thanks for the suggestion @JonMikelV to use the Delete command from the command line. I am unfortunately struggling to successfully execute this command, despite following your instructions.

To recap, now that I have Duplicati upgraded to the new version, the current problem is that when I try to run the backup on the webGUI, I now get the error

Unexpected difference in fileset version 6: 2/11/2018 2:20:25 PM (database id: 2), found 39 entries, but expected 41

I then follow your advice and tried to fix this by running the Delete command as follows from the command line feature in the webGUI, where the command is basically

Delete <URL not changed from what is specified in the Target URL box> --version=6

I initially get the message Running task: Starting... in the URL bar and the webpage saysRunning commandline entry and below that Running.... stop now

Nothing happens after this; it is as if the program becomes stuck. Eventually after ~5 minutes, I get a message saying Connection is lost, connecting in 8 seconds, then once the 8 seconds are counted down, another message saying Connecting to server ... . It then goes into another long ~8 minute pause, finally giving me the message:


Connection error, retry in 2 sec …
Connection lost, data has expired …

Clearly, I’m doing something wrong! Again, I’m not sure how to log this to help figure out what is causing the problems.

Alternatively, I have tried to open a Command Prompt window, then change directories to where the Duplicati installation is located and run Duplicati.CommandLine.exe from the command prompt:

c:\Program Files\Duplicati 2> Duplicati.CommandLine.exe delete ssh://hda:22//var/hda/files/drives/drive6/Backup_Coolermaster_Data --version=6

The program comes back and asks me to enter encryption passphrase, which I then enter. I then get the message

ErrorID: DatabaseFileMissing
Database file does not exist: C:\Users\gstre\AppData\Local\Duplicati\65837583836790896782.sqlite

I am at a loss on what to try next. I did try to roll the software back to the previous version but all that did was to bring back the initial problem that I posted about.

Next steps?

Did you see my earlier post? I’m not certain how much it may help, because logging coverage varies. Things like backup are well covered. I don’t think there’s much for the internal web server, or the update processing.

Maybe, or maybe not. Not much information yet. It sounds like you saw an error popup in the middle of your screen where the browser code complains it can’t get to the server (code talks back and forth). Seems odd.

Duplicati.CommandLine.exe is unaware of the options set for the jobs found in the web UI. It’s independent. Running the UI Export option for a backup job will let you copy and paste a suitable commandline, however using the UI Commandline option avoids the need to transcribe. Too bad it was having some server issues. Don’t try Duplicati.CommandLine.exe on the same backup at the same time as the server might be using it.

Did it do entire “backups running”, “wait”, “update”, “download”, “nothing”, “reboot”, “can’t connect” or less? Please also note that there are two steps, first an Install, then Activate (which is the less reliable operation). These seem to be available both from a popup at the bottom of the screen, and regular text in a paragraph.

I’m losing track of versions. At one time you had a base with possibly a partial in an updates folder. You did a zip file install over the base Program Files version I guess (which I haven’t tried before) but somehow got back to Ordinarily to downgrade you’d delete the upgrade. How did you get There are also database version changes to deal with, as described in the “Downgrading” document above.