Unrecoverable "Detected non-empty blocksets with no associated blocks!"

I have been running Duplicati backups for many months. I have started getting the error, “Detected non-empty blocksets with no associated blocks!” I have tried to run a repair and it completed successfully but the same error keeps happening on subsequent runs. I am running

The only event that I can think might have triggered it is that I migrated my hard drive between SSDs. I used Partition Wizard to do a direct copy of the old drive onto the new one, and then started booting from the new drive instead. Windows and my applications all worked seamlessly, so I don’t think anything went wrong in the transfer. But perhaps that has confused Duplicati somehow?

What are my options? Repair doesn’t seem to work since it completes successfully. Is this resolved on a canary build perhaps?

At least one case was fixed. You could try picking up v2.0.4.30- although the fix was actually first in canary (which had serious issues – as did several successors). Note that return to beta will be awkward due to DB changes. In your DB folder there are backups of the old DB, but new files on the destination won’t be known to the DB if you put one back in use. Easiest path is to move forward. There might be an Experimental and/or Beta soon. You can change Settings away from Canary, after hand-picking one to test. Or at least don’t be the first to take new Canary unless you’re adventurous. Avoid, but might be an option if you want a Canary with a little more age than…

CheckingErrorsForIssue1400 and FoundIssue1400Error test case, analysis, and proposal #3868 (Issue)
Fix for issue1400 #3872 (Pull request)

Sometimes one can also work around the problem (if this is the fixed problem of backing up a file while it’s changing) by excluding certain folders from the backup, for example the one with Duplicati’s databases is troublesome because the DB (especially its sqlite-journal file) changes due to backup, so triggers the bug. People who back up an entire drive or user profile may hit this. Not sure if this is your case, but it’s typical.

You can post a link to a DB bug report if you like. It might be possible to see if the problem is the fixed one.

Thanks for the info, ts. I don’t think I want to mess around with the canary builds in that case (dealing with the DB changes sounds painful). I’ll wait for an updated beta release.

Incidentally, I tried to create a bug report this morning, and have just noticed that it is still running now… so it seems there might be some pretty serious underlying issues.