Unable to delete backup (solved)

Dear members,

I have a backup (job) that fails to run, says it has found X remote files that are not recorded in local storage and that I might run a repair action.
Well, it is unable to repair it. As it was only a test and not so important I want to delete it.

It does not want to be deleted it seems. Is there an option to wipe/purge everything concerning this task/job?

I’ve not rub Ohio run into (what is up with my auto-correct???) this issue yet so I have a few questions that could help narrow down the problem.

  1. Are getting an error message when you try to delete the job?
  2. Are you using the GUI or the command line?
  3. What version of Duplicati are you using?
  4. Is it running as the tray icon or a service?
  5. What OS are you running it on?
  6. What type of destination is the job using?

Note that the “remote files not in local storage” message can happen if you have more than one job pointing to the same destination folder (and are not using a job prefix).

@JonMikelV Thanks for responding and giving hope to resolve this issue.
Since a few minutes ago the issue is resolved.
I think it went like this.
When I tried to delete the backup I got error messages stating I could repair. I followed the advise offered in these error messages, got other error messages, tried deleting, purging (and others) and even added the “–allow-full-removal” option. But I lost sight of the original command.
All this while gathering the information for your 6 questions. Then I read your note on “same destination folder” and realised that is what I am doing because the backups are on a raspberry pi 3 with an external hard disk attached and the target is the same folder as the other well working backup.

  1. yes, about the X number of remote files that are not recorded in local storage, please run repair.
  2. GUI
  4. Tray icon
  5. windows 10
  6. raspi3 external HD by SSH.

After fiddling around I suddenly saw the delete option again and tried it anew. It worked!

And I learned that each backup should go into its own folder :wink:



Yay - I’m glad you got it working!