Ubuntu - Failed to load process type Duplicati.Library.Common.IO.VssBackupComponents

I’m getting this error on Ubuntu 18.04
Loaded mono-devel.
Tried using;
Same results.
The file it’s complaining about IS there.

ls -al /usr/lib/duplicati/Duplicati.Library.IO.dll
-rw-r–r-- 1 root root 46032 Feb 18 05:16 /usr/lib/duplicati/Duplicati.Library.IO.dll

Any idea why this error keeps popping up?

Failed to load process type Duplicati.Library.Common.IO.VssBackupComponents assembly /usr/lib/duplicati/Duplicati.Library.IO.dll, error message: Could not load type of field ‘Duplicati.Library.Common.IO.VssBackupComponents:_vssBackupComponents’ (1) due to: Could not load file or assembly ‘AlphaVSS.Common, Version=, Culture=neutral, PublicKeyToken=959d3993561034e3’ or one of its dependencies. => System.TypeLoadException: Could not load type of field ‘Duplicati.Library.Common.IO.VssBackupComponents:_vssBackupComponents’ (1) due to: Could not load file or assembly ‘AlphaVSS.Common, Version=, Culture=neutral, PublicKeyToken=959d3993561034e3’ or one of its dependencies.
at (wrapper managed-to-native) System.RuntimeTypeHandle.type_is_assignable_from(System.Type,System.Type)
at System.RuntimeTypeHandle.CanCastTo (System.RuntimeType type, System.RuntimeType target) [0x00000] in :0
at System.RuntimeType.IsAssignableFrom (System.Type c) [0x00020] in :0
at Duplicati.Library.DynamicLoader.DynamicLoader`1[T].FindInterfaceImplementors (System.String additionalfolders) [0x000b7] in <67a23f1c898f45bfaf9732eaccf77a51>:0

I have the same issue on CentOS 7.

Doesn’t anyone have a fix?

Every backup I get a “Warning” report - which is a problem. [Hard to have the end-user decipher what this “warning” is about, and if they should take corrective action or ignore it.]

I’d be glad to simply suppress the loading of the module (and warning). Since this is a *nix platform, VSS support seems kind of nuts to even be worrying about anyway.

@gsloop.treo_gsloop.t I just received the very same warning for the first time (running on my server - ubuntu 16.04) however all previous backups ran without warnings. The only change made at my end prior to receiving the warning was a suite of security updates installed this morning - possibly linked to one of those changes?

Quick follow on - I’ve just manually triggered a manual backup (to further interrogate the logs) however the backup completed without any warning this time. I’ll continue to monitor for this error anyhow.

I am seeing it intermittently on my Linux Mint laptop. Some backup jobs have the warning, others do not.

I do too have this exact warning. It only occurs if my computer is not powered on at the time backup should take place. So, when the computer boot up, naturally, duplicati starts to backup to my server and at that time it shows error. Manually running backup afterwards do not reproduce this error.

Any updates on this? I am getting those warnings from time to time on all my computers. I am not sure whether it has any negative impact on the backup. I am on Mac OS X High Sierra, Mono, Duplicati Previous beta version never caused this warning. My computers are awake at time of scheduled backup and warning seems to be issued right at the beginning of backup.

It is being discussed on this Github issue thread. You can ignore this warning - it is just an annoyance more than anything and doesn’t affect backups.

Should be fixed in a future version.

So, looking at the github discussion it doesn’t look like there’s any “solution” for mere mortals.
I’m using Duplicati in production [yes, production - I understand the limitations, please don’t bug me about it!] and the end-user/client gets the email notices.

It’s not very re-assuring to tell the user they should just ignore “warnings” - well, not all warnings, just some warnings…if you see something about “VssBackupComponents” way down in the footers, just ignore those. But if you see other warnings, be sure to let me know.

Yeah - that really doesn’t work so well.
So I can’t turn monitoring these backups over to a non-tech person because they’ll never be able to tell if there’s a problem or not.

So, I’m pushing again here - it needs fixing. If I can remove a file, and get the warnings to go away, I’m glad to do that. But at the moment, I have no way of resolving this, and I really do need it to go away.

So, any guidance that’s better than “just ignore those errors” would be highly appreciated. [Though I appreciate the comment - I’m not knocking you - that backups are not compromised. (I already assumed that)]

1 Like

Should be fixed in the next release, but you may not want to jump to the Canary channel for just this.

A workaround someone proposed was to copy the DLLs from another system, like a Windows computer. (Make sure it’s the same version of course.)

I just tested this idea and it worked for me. I copied:


from C:\Program Files\Duplicati 2 and put them in /usr/lib/duplicati on my Linux machine. I do not know if that first one is needed or not, but it can’t hurt.

1 Like

https://github.com/duplicati/duplicati/releases .zip files have the file too, if that’s an easier way…
Just extract and drop the file in the Duplicati folder. If need be for client, you could package it up.

There’s actually another solution, but I don’t think it fits your case. I think any update has all files.
Updating to a Canary release such as would install the update in a different area, then whenever Duplicati starts, that’s where it would run from. The update has all files, so no warning.

Problem is – Canary is a test release with new fixes and new bugs. You could do something odd, installing and then updating to using Settings to change the Update channel to Beta, but that seems like a very roundabout solution.