TrayIcon error with version

After reinstalling the file duplicati- over my old version I’m getting the error on TrayIcon launch:

Problem signature:
  Problem Event Name:	CLR20r3
  Problem Signature 01:	Duplicati.GUI.TrayIcon.exe
  Problem Signature 02:
  Problem Signature 03:	59ddfe6b
  Problem Signature 04:	Duplicati.Server
  Problem Signature 05:
  Problem Signature 06:	59ddfe69
  Problem Signature 07:	102
  Problem Signature 08:	68e
  Problem Signature 09:	System.IO.FileNotFoundException
  OS Version:	6.1.7601.
  Locale ID:	1046
  Additional Information 1:	da83
  Additional Information 2:	da83a87bfe0aee6e097244686698b06f
  Additional Information 3:	48d4
  Additional Information 4:	48d40e384841fbb7921d7e3f5beccad

Using the Debug option with Visual Studio I got the following call stack:

>	Duplicati.Library.AutoUpdater.exe!Duplicati.Library.AutoUpdater.UpdaterManager.RunFromMostRecent(System.Reflection.MethodInfo method, string[] cmdargs, Duplicati.Library.AutoUpdater.AutoUpdateStrategy defaultstrategy) + 0x490 bytes	
 	Duplicati.GUI.TrayIcon.exe!Duplicati.GUI.TrayIcon.Program.Main(string[] args) + 0x85 bytes	

Yeah, it instantly crashes here as well. Win7x64. Installed it over experimental branch.

TBH, no matter which Canary I install (tried back until 2.8), they all crash.
EDIT: Also the …2.1 now creates a crash. Hmmm. Installing over other versions was probably bad.
Duplicati is not a service here, it’s just running as the tray application. Well, not now any more…

Uninstall via Control Panel - Programs // Then install Canary
…resolved the issue for me.

Beware that Duplicati stores the updates in %LOCALAPPDATA%Duplicati\Updates. If it finds a newer version here it will start that instead, so make sure you wipe the old updates here, otherwise downgrades will not work.

The next version of Duplicati ( will use a new update method so hopefully this problem will go away.


Did you ever get this resolved? I’ve run into similar issues (though I abuse my system for testing) but for me and apparently Tapio doing a full uninstall / re-install resolved the issue. (Tapio didn’t mention it, but you might want to export any existing backup jobs to a file before the un-install…just in case.)

I made a complete uninstall (losing my schedules) and reinstall the tray icon is working again.

Thanks for confirm that process worked for you.

Just as an FYI I believe the next few releases will be introducing a new upgrade process that should hopefully resolve this issue.

Thanks, i will be great.