Tray icon Service Mode [WINDOWS*

Hi guys,
I often install duplicate in service mode on Windows system, I also wanted to activate the icon in the tray, otherwise the user does not know if duplicates is running.
How can I enable the icon?

Thank you

You can use the TrayIcon and have it launch at startup, but you need to make sure you use the --no-hosted-server command line parameter.

I started from the command line, but I don’t see the icon.
Would it be possible to have the icon only as a duplicate status display?
Is it possible to activate the icon in Service mode avoiding the command to enter the command?
Thank you

Once you have installed Duplicati as a service all you need to do is right-click on the desktop icon go to Properties then add --no-hosted-server to the end of the target line, after the quotes.

Done, but it doesn’t work as it should, the icon appears if I click on it opens the configuration page with port 8300 only that I duplicate works on service on port 8200 so it doesn’t find anything.
It would be enough to associate the duplicate icon at the active service, it is not needed that when I click on it opens up duplicates, but only for information if it is at rest or is working or error.

Once Duplicati is running as a service and the trayicon is closed, you will still be able to access the GUI by going directly to http://localhost:8200/ , does that work?

As far as the active service, there is nothing to associate. If the service is running and the TrayIcon icon properties is set to --no-hosted-server you should be connected to the service instance on port 8200.

If the --no-hosted-server is not specified, in the wrong place or otherwise not correct then the TrayIcon will launch a new server instance on port 8300 and connect to it instead.

I’m not sure how you setup Duplicati to run as a service but I found this post by johnvk to be a good set of instructions.

So I decided to pass in Service Mode, after various difficulties I managed to point the path I used in No Service Mode.
Originally the trouble pointed to f:\duplicati since I activated the service I didn’t find an option on duplicates where to say that the path you use by default is not that but must use my personalized, after various research I found the parameter, These are my parameters to activate the service:
Duplicati.WindowsService.exe install --webservice-interface-loopback --webservice-port=8200 --portable-mode --server-datafolder=F:\Duplicati
only that the configuration parameters resided on C: User Administrator Appdata Local duplicates when I went to start duplicate asked me a password, while before I had no password, then I remembered that long ago I used a password, from I realized that yes the databases resided on f: duplicates, but the settings resided under the user folder,
Maybe in the next version of duplicates it would be interesting to view the path where the duplicate settings dBase resides, or at least have the possibility to change path from the graphics console

set the DUPLICATI_HOME env variable machine wide will sort where config resides for all users

I understand but I always have to act as a command line to view the route. If possible implement on graphics.
To find out the current route, what string should I type?

I 've had the same issue, especially with installations with password protection on the web interface.
You need to submit a few additional parameters to the Tray icon shortcut:

Duplicati.GUI.TrayIcon.exe --no-hosted-server --server-datafolder=<path_to_Duplicati-server.sqlite> --read-config-from-db

Copy the shortcut to C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup for auto starting the tray icon when any user logs in.

In the Duplicati Web UI, go to Settings and enable Prevent tray icon automatic log-in if you want to specify the access password when you use the tray icon to access the Web UI.


I did as you wrote, but it opens duplicate with 8300 port, he fears duplicate-server.sqlite from another part …
“C:\Program Files\Duplicati 2\Duplicati.GUI.TrayIcon.exe” —no-hosted-server --server-datafolder=C:\Program Files\Duplicati 2\data\Duplicati-server.sqlite --read-config-from-db

Is there a command to view the exact path that reads?
My service folder resides on C:\Program Files\Duplicate2\Data but obviously does not read this database

Is it possible to have the tray icon only as a state?
If you click on it, you don’t open any graphics page

Not sure if it’s just how this was entered into your forum post, but you are using the wrong hyphen/dash here. Instead of —no-hosted-server it should be --no-hosted-server.

“C:\Program Files\Duplicati 2\Duplicati.GUI.TrayIcon.exe” —no-hosted-server --server-datafolder=C:\Program Files\Duplicati 2\data\Duplicati-server.sqlite --read-config-from-db

That still shows the wrong dash.

“C:\Program Files\Duplicati 2\Duplicati.GUI.TrayIcon.exe” --no-hosted-server --server-datafolder=C:\Program Files\Duplicati 2\data\Duplicati-server.sqlite --read-config-from-db

correct excuse, however nothing happens, the icon does not appear in the tray

You may need to put quotes around the datafolder path, since it has spaces:

"C:\Program Files\Duplicati 2\Duplicati.GUI.TrayIcon.exe" --no-hosted-server --server-datafolder="C:\Program Files\Duplicati 2\data\Duplicati-server.sqlite" --read-config-from-db

Copy/paste that above line into your shortcut properties and try again.

nada, no run tray icon

If you run it with a startup shortcut it won’t run elevated so can’t access the data folder.

It needs adding as a custom startup event using task scheduler, setup the trigger as you like but make sure the service has already started before the tray icon executes.

I tried to start it to computer turned on but nothing the icon does not appear.
Use Windows7

I think --server-datafolder use has gone astray. It’s a folder not a file. I fed it a nonexistent path, and it made a folder of that name, with Duplicati-server.sqlite in that, all as one might expect. The manual says:

Duplicati needs to store a small database with all settings. Use this option to choose where the settings are stored. This option can also be set with the environment variable DUPLICATI_HOME.

and this is also where the job databases (name is usually random letters then .sqlite) are. Where are desired ones, as confirmed by things like file dates? I don’t want to be tripping over old mystery material.

So is it the one above, showing current files, and not below? Do you think you use and want a password?

is a critical question that hasn’t clearly been answered (though it’s hard to tell). Can @tigro11 do yes/no?
I don’t see much messing around with the service here, so it would be nice to have a healthy starting point.

It would be useful to use the Start menu to look for Task Manager and Run as administrator to look on Details tab to see which Duplicati processes are up now. Service should have 3. TrayIcon should have 2.

Getting extra Duplicati processes when starting things is easy, and confusing. I think one can also leave a mess behind if one uses Control-C. Windows can also hide a TrayIcon, needing Show hidden icons use.

Even without that, sometimes Duplicati processes appear briefly and give up, and that activity is significant.
You can’t see what happens at a process level without looking. Alphabetic Name sort is a good way to look because it should get all of the Duplicati processes in a row, so it will be easier to watch what’s happening.

Turning on the Command line column can be useful, if one isn’t certain what options something was given.