Theme not saving, password issue

I keep trying to save the theme to black, but it goes right back to white. I don’t store cookies or cache, could that be it? If so it should store in the program.

Also, I set a password and it never asks me for it.

Using Pale Moon browser.

The theme color is stored in a cookie, so you’ll have to enable the cookie or stick with white mode currently.

The password prompt not appearing may be happening if you always open the web UI by using the tray icon. it will log in for you unless you enable a setting that was recently introduced (2.0.3.9 I think).

If you log out of the Web UI and refresh the page does it prompt you for login?

The password works if I don’t use the tray icon. The fact I have to use a cookie for the theme to change isn’t great. I never store cache and cookies.

How do I get rid of the tray icon?

If you’re running the newer version with this Prevent tray icon automatic log-in option you don’t need to disable the tray icon.

If you’re really set on getting rid of the tray icon it depends on what OS you’re using.

I’m using 2.0.33 beta. I don’t see that option. I need to prevent people from launching and logging into the software. Since the tray icon doesn’t respect the password I need the tray icon to disappear.

It’s worth noting that the tray icon is only available to people logged into your user account.

Any other user starting the tray icon will be starting a new Duplicati server with their own blank configuration.

What OS are you using?

I need to hide the tray icon on a computer that my parnets use. I don’t want them monkeying around with it. As it stands now, the password is useless with the tray icon, and I don’t see that option in the program to hide the tray icon. Using Windows 7, but I have all my computers show task bar icons and not hide them. I’m not going that route.

Hi @F22Simpilot, welcome to the forum!

The automatic tray icon login feature wasn’t added until 2.0.3.7 - and honestly I wouldn’t recommend updating past 2.0.3.5 canary for the moment (and 2.0.3.3 beta is the most stable version for now anyway):

There isn’t a setting to disable the tray icon itself - you just need to remove it from the user’s Startup folder (depending on how you installed it, it might be in the Startup folder for “All Users”).

Of course they could still run it from the Start menu (or direct from the C:\Program Files\Duplicati\ folder) so you may be better off running Duplicati as a service (still with a GUI password). It sounds like the likelihood of your users manually running the tray icon with the --no-hosted-server parameter is pretty low…

I deleted the shortcut in the startup folder, but that renders the program useless for automated backups since it’s not running. Can I run the program as a service without the tray icon? If so, how?

You sure can! :slight_smile:

Thanks. I’ll go over that all again and try to get this working as a service. Looks all pretty hack to say the least and so I’ll echo what some others have said and say that the program installer should have an option to install as service.

1 Like