The supplied option --auth-username is not supported and will be ignored

[Warning-Duplicati.Library.Main.Controller-UnsupportedOption]: The supplied option --auth-username is not supported and will be ignored

Backing up to Google Cloud Storage, I’m getting this warning. Have looked at the similar topics but haven’t been able to draw a conclusion as to whether it is something to be concerned about. It constantly turns the Duplicati icon yellow.


yes these options are not supported for your storage (if you use the proprietary API for Google storage that is). I don’t know how it’s possible that you have these options in your configuration, it should not happen. Maybe you upgraded from an older Duplicati version ? Whatever the reason, you should be able to edit your job and remove these options from the advanced options.

Fairly new to Duplicati (approx 1 month now). Nothing appearing in advanced options, however perhaps I should add something via advanced text to make it not use auth?

Hmm, there is however something prefilled here in passphrase (edited for screen shot). Is that what it’s talking about?

No, passphrase has nothing to do with auth options; passphrase is used to encrypt data before sending it to the backend, it’s at the sending phase that auth is used.
I don’t see how passphrases could not match, I don’t think that you can validate the job creation if they don’t.
To come back to the advanced options, try to export the job to file and open the resulting file with a text editor to see if you can find the offending options.

Another way to handle this is on Destination screen, use three-dot menu to far right of title.
Copy Destination URL to Clipboard and Import Destination URL can both edit URL.

The typical path is to change from a Storage Type that used a username to one that does not.
Seeing it might help recall. I think going back to prior type momentarily is also a delete chance.
The UI will probably keep your Google settings on return. If anything gets hurt, just don’t Save.

Changing backend type leaves invalid backend options #3082 is the general issue, but the key
word there is invalid. Sometimes there are other options that are still valid. Want those kept?
Regardless, suggest you see if you recall what you did, and take a look at the actual extra one.

1 Like

Forgive me for resurrecting this zombie thread, but I have this exact issue. I’m a new Duplicati user, I installed the beta for the first time (so it’s not caused by a botched upgrade). I configured a backup to use Google Drive (so it’s not caused by a change in storage backends) and I get the two warning messages for almost every action I take in the web interface (and for each backup run). I did not manually set the two variables it complains about (“–auth-username”, “–auth-password”), nor can I find a way to disable them, they don’t show up under “Advanced” anywhere.

Is there a text config file I can edit to remove the options? I looked and I could only find .sqlite files.

[EDIT] Oh, sorry, never mind, re-reading the thread my brain successfully parsed the workaround (editing and importing the Destination URL). This worked fine. BUT: I noticed that the --auth-password supplied is the passphrase of the backup job. It probably defeats the purpose of encrypting the backup with a passphrase to protect it from Google’s prying eyes if that passphrase is then supplied to Google with every access to the storage backend.

Is --auth-username meaningful? Any password autofill in a browser or password manager?
Because Duplicati GUI is one web site, password fillers may confuse the different passwords.
There was a fix for some of this, but maybe your software (which is what?) isn’t respecting it?
Turn off anything you can think of that might be storing password, and what about username?

Invalid option’s ignored so it won’t be sent. Google Drive doesn’t even do username/password
directly from the application. Your initial setup turned into some tokens represented by AuthID.

How we get along with OAuth

Good point, the --auth-username is the name of the backup, and it matches password information stored in Chrome’s password manager (protected by a sync passphrase). So Chrome is probably the culprit. I’ll remove the credentials from Chrome and I’ll store them in Keepass instead.

Thank you for the explanation!

1 Like

I get two warnings for “The supplied option --auth-username is not supported and will be ignored” each time I do a backup.

I am backing up to DropBox. The files appear in the destination folder. How do I overcome these warnings?

For any people who see this issue and want a workaround, please try out the solution posted at top.

This worked a treat for me. I had originally setup the backup as an Amazon S3 type, then changed it to DropBox. I created a new backup of type DropBox from scratch and the problem didn’t appear. I then deleted the original backup. has this fix now, but most people should use Beta, not Canary.

Fix hidden username and password options when changing backends, thanks @Jojo-1000