The SMTP server does not support authentication


I’m trying to configure email notification on my uncle’s laptop but cannot get the connection to the SMTP server working. I use the following to test the configuration on the command line (configuration copied from Outlook (which works), *** subsituted for privacy):

Duplicati.CommandLine.exe send-mail --send-mail-to=*** --send-mail-from=*** --send-mail-url=smtp:// --send-mail-username=*** --send-mail-password=*** --send-mail-subject=Testmessage --verbose --log-level=profiling

However, I keep getting the following error:

System.NotSupportedException: The SMTP server does not support authentication.

Apparently Duplicati is trying to use authentication while the SMTP server does not support it.

I’ve tried various values for “starttls” but that didn’t make a difference. Any other port (e.g. 465 or 587) does not work (no reaction from sever). I’ve also tried “smtps:” instead of “smtp:” but again no success. I’ve also tried all combinations of the above, no luck.

How can I fix this?

Best regards,
Patrick Vestjens.

makes me think you could avoid authentication by giving neither the username nor the password, but you might still get denied because if you were not denied, then anyone could send mail (e.g. spam) anywhere.

Open mail relay is the term for this, and it’s bad practice. Generally port 25 these days is primarily used for relaying between mail servers. 587 or 465 are for client submission, however I can’t make a connection to those from here, only to 25, so maybe they’re only accessible from an IP address, but would they want authentication as well? If they only accept mail from their network, but you’re not on it, are you stuck?

E-mail instellingen says outbound e-mail uses port 587 (another sign 25 won’t do). When and if you can finally get connected, port 587 is usually starttls (switches to TLS), and 465 is smtps.

Cleartext Considered Obsolete: Use of Transport Layer Security (TLS) for Email Submission and Access

EDIT: Actually they might still have network restrictions on port 25 to keep it less than completely open, but it seems to go against usual practice and their documentation. The best plan might be to ask them to help.


Thanks a lot for your quick and extensive reaction.

I also found the page saying you should use port 587 for outbound traffic but that port doesn’t do anything. So then I had a look at the Outlook settings and found out that it is using port 25. I agree that’s quite old fashioned but for Outlook it seems to work, probably only within the network itself.

I found another thread on the subject (Tweakers) but it is in Dutch and the moral of the story is that is not really helpful in configurating third party applications.

But I still wonder, if it works for Outlook, then why can’t I get it to work for Duplicati? In the end it should be able to do the same trick, right?

Best regards,

Are you on the network now? If so, you might have more leverage, but even just being a customer seems like it ought to give you a bit (in spite of any poor attitude they might have towards third party email).

And if you are on the network, and if port 587 won’t even connect (any idea how long? – my test timed out), then there’s an error in their documentation that they should be accountable for, regardless of poor attitude.

Did you try turning off the authentication in Duplicati as previously suggested? Omit both of these settings:

--send-mail-username=*** --send-mail-password=***

If they still complain you’re trying to authenticate, then I misread something. If they let you send, then great.

You might still get some complaint if you’re not on their network. They still need to control spam somehow.

MailKit is the library used by Duplicati and recommended by Microsoft (oddly, in favor of their own attempt).

No way to verify anonymous smtp connection #363 was a question somewhat similar to yours, where this reply was the author’s comment that you can omit authentication if your provider allows anonymous relays. Such omission is (per code lines I showed) what you get by omitting both the username and the password.

If all else fails, you might need to get a different service provider. You could certainly ask them if that’s their recommendation (it might raise their attention level), but in reality a free additional provider could be added.

Have you enabled 3rd party app access to your Gmail account? You do this from the Gmail settings page. It allows “less secure” apps from connecting to the service. Follow the information in the following link:

I suspect that access is more for –send-mail-url than –send-mail-to, but switching to Gmail as the sender might be a workaround if won’t cooperate. Gmail has quirks (e.g. security note) but is often used.

Thank you for the good suggestions and elaborate explanations. Next time I visit my uncle I’ll give it a try. I’ll keep you posted.

Best regards,