# Synology: "unable to find log in lookup table" on Home-\>\[backup\]-\>Restore files...?

**URL:** https://forum.duplicati.com/t/synology-unable-to-find-log-in-lookup-table-on-home-backup-restore-files/1660
**Category:** Installation
**Created:** [December 6, 2017, 7:08pm UTC](https://forum.duplicati.com/t/synology-unable-to-find-log-in-lookup-table-on-home-backup-restore-files/1660 "2017-12-06T19:08:47Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![conrad](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/c/ebca7d/32.png) [@conrad](https://forum.duplicati.com/u/conrad)
#### Post date: [December 6, 2017, 7:08pm UTC](https://forum.duplicati.com/t/synology-unable-to-find-log-in-lookup-table-on-home-backup-restore-files/1660/1 "2017-12-06T19:08:47Z")

</div>

Have just installed 2.0.2.13 on a Synology NAS; I’ve made a backup, but when I (through the web GUI from a remote PC) click Home, select that backup and click “Restore files…” I get the above error; in more detail:

```
Failed to connect: Unable to find log in lookup table, this may be caused by attempting to transport call contexts between AppDomains (eg. with remoting calls)

```

Running it from the command line, the error appears to be from [this point in the source](https://github.com/duplicati/duplicati/blob/4dcf386312e964535c08703ace347aaff9cdf493/Duplicati/Library/Logging/Log.cs#L218):

```
No certificates found, you can install some with one of these commands:
    cert-sync /etc/ssl/certs/ca-certificates.crt #for Debian based systems
    cert-sync /etc/pki/tls/certs/ca-bundle.crt #for RedHat derivatives
Read more: http://www.mono-project.com/docs/about-mono/releases/3.12.0/#cert-sync
System.Exception: Unable to find log in lookup table, this may be caused by attempting to transport call contexts between AppDomains (eg. with remoting calls)
  at Duplicati.Library.Logging.Log.get_CurrentScope () [0x00000] in <filename unknown>:0 
  at Duplicati.Library.Logging.Log.get_LogLevel () [0x00000] in <filename unknown>:0 
  at Duplicati.Library.Logging.Log.StartScope (ILog log) [0x00000] in <filename unknown>:0 
  at Duplicati.Library.Main.Controller.RunAction[ListResults] (Duplicati.Library.Main.ListResults result, System.String[]& paths, IFilter& filter, System.Action`1 method) [0x00000] in <filename unknown>:0 
  at Duplicati.Library.Main.Controller.RunAction[ListResults] (Duplicati.Library.Main.ListResults result, IFilter& filter, System.Action`1 method) [0x00000] in <filename unknown>:0 
  at Duplicati.Library.Main.Controller.List (IEnumerable`1 filterstrings, IFilter filter) [0x00000] in <filename unknown>:0 
  at Duplicati.Server.Runner.Run (IRunnerData data, Boolean fromQueue) [0x00000] in <filename unknown>:0 

```

… anyone seen this before?

I can still restore by going to the Restore menu, and selecting the backup that way.

---

<div class="post-metadata">

### Author: ![JonMikelV](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/439d5e/32.png) [@JonMikelV](https://forum.duplicati.com/u/JonMikelV)
#### Post date: [December 7, 2017, 4:58am UTC](https://forum.duplicati.com/t/synology-unable-to-find-log-in-lookup-table-on-home-backup-restore-files/1660/2 "2017-12-07T04:58:57Z")

</div>

Sounds like a variation of the infamous mono certificates issue.

So you know if you have the `ca-certificates-mono` package installed on your destination?

---

<div class="post-metadata">

### Author: ![conrad](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/c/ebca7d/32.png) [@conrad](https://forum.duplicati.com/u/conrad)
#### Post date: [December 7, 2017, 6:12pm UTC](https://forum.duplicati.com/t/synology-unable-to-find-log-in-lookup-table-on-home-backup-restore-files/1660/3 "2017-12-07T18:12:51Z")

</div>

> [@JonMikelV](#):
>
> Sounds like a variation of the infamous mono certificates issue.

Yes indeed, turns out it is the issue thanks: the lookup table complaint looked to me to be unconnected, but [having addressed the certificates issue separately](https://github.com/SynoCommunity/spksrc/issues/3033), I now find the log error has vanished.

---

<div class="post-metadata">

### Author: ![JonMikelV](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/439d5e/32.png) [@JonMikelV](https://forum.duplicati.com/u/JonMikelV)
#### Post date: [December 7, 2017, 6:27pm UTC](https://forum.duplicati.com/t/synology-unable-to-find-log-in-lookup-table-on-home-backup-restore-files/1660/4 "2017-12-07T18:27:43Z")

</div>

Glad to hear you got it working - and thanks for the SynoCommunity mono link as well!
