Support Backup to Azure Germany?

Hi there,

first of all, thanks again for your great work on Duplicati ! I just tried out Cloudberry in a Hyper-V-virtual-machine on a fresh Win2k16-server and the first thing Cloudberry did after some backups was: crashing !

Back to topic: is there a way to change the preset cloud providers as I did not find a way to sync to Azure Germany? The domains Microsoft uses differ to international Azure-Servers, e.g. for blobs it is *

What URL do you need to use for Azure Germany? If it’s not in the list, you should be able to select “Custom server url ()” and put it there…

Maybe I am blind, but where do I find that entry?

It is neither under “backup destination” > “storage type” nor when I tip on the three points right to that entry.

If I tip on the three points, there is a way to make custom URL-entries, but where do I put a different server address?

What could be done there is to say azure://…, but what format should the server-URL have to look like?

As I have seen now, custom server URL is only supported for S3-compatible-storage, which Azure is not.

Oops - my mistake, I actually DO know the different between Amazon and Microsoft…REALLY! That’s what I get for posting at odd hours… :blush:

So what you need is either a specific “Azure blob Germany” option or a selector list under “Azure blob” similar to what’s currently seen in “Amazon S3”?

Yes, that´s what seems to be missing in options for my requirements.

And: sorry, did not meant to be rude with the reference to Azure and S3.

No offense taken, it was a silly mistake on my part in the first place. :slight_smile:

I’ll try to look up who put the original Azure code in and see if they are available to look at adding what you need.

Thanks a lot, Jon !

If you can get rclone to link with your cloud provider, you could try that as a backend. Available in latest canary.

Thanks for the hint, but as far as I see there also is no way to tell rclone to sync to different server addresses than the ones that are build in. And the ones build in to rclone are also the US-Azure-blob-servers.

Well, it looks like the original coder of the Azure Blob backend hasn’t been active with the project for a few years now. :frowning:

At this point I think your options include:

  • wait for somebody else to implement it
  • code it yourself
  • post what you want on GitHub and put a Bounty on it and hopefully others will add to the bounty and somebody will code it

I’ve moved the topic from Support to Features so hopefully that will get a few more developer eyes on it. :crossed_fingers:

I guess you found a solution already, but I just had the similar problem of connecting rclone with Azure Germany.
It seems like in the current version of rclone (I have 1.42), you have a “endpoint” option, which you can use to connect to Azure Germany.
I entered as the endpoint and then I was able to connect.
Hopefully this will hope someone who stumbles across this thread due to a similar problem :slight_smile:

1 Like

Hi @gemma, welcome to the forum - and thanks for sharing what worked for you!

I’m not sure if it’s truly a “solution” as it seems to be using rclone instead of the native Azure Germany API, but I went ahead and flagged your post as the solution in case others need to find a way to “just get it working”. :slight_smile: