Storage type empty


#1

Hi,

I’m using Duplicati - 2.0.2.1_beta_2017-08-01 over Win7 x64 VM.
I configured 4 months ago a backup job, which working fine so far (800GB data).
I wanted to modify backup conf, and and can’t see any storage type anymore.
The initial storage type is OVH openstack, and when I backup backup conf, I can see the storage, with the right credentials.
Help welcome!

B Fontaine

Here is the backup conf :

{
  "CreatedByVersion": "2.0.2.1",
  "Schedule": {
"ID": 1,
"Tags": [
  "ID=1"
],
"Time": "2017-12-08T18:00:00Z",
"Repeat": "1D",
"LastRun": "2017-12-07T18:00:00Z",
"Rule": "AllowedWeekDays=Monday,Tuesday,Wednesday,Thursday,Friday,Saturday,Sunday",
"AllowedDays": [
  "mon",
  "tue",
  "wed",
  "thu",
  "fri",
  "sat",
  "sun"
]
  },
  "Backup": {
"ID": "1",
"Name": "Sauvegarde Bureautique",
"Tags": [],
"TargetURL": "openstack://Duplicati prod/Atrium/?openstack-authuri=https%3A%2F%2Fauth.cloud.ovh.net%2Fv2.0&openstack-tenant-name=OBFUSCATED&openstack-region=GRA1&auth-username=OBFUSCATED&auth-password=OBFUSCATED",
"DBPath": "C:\\Users\\admin.OBFUSCATED\\AppData\\Roaming\\Duplicati\\AWBYICHASA.sqlite",
"Sources": [
  "C:\\Libel\\",
  "\\\\atrisme\\candidatures\\",
  "\\\\atrisme\\projets\\",
  "\\\\atrisme\\outils\\",
  "\\\\atrisme\\direction\\"
],
"Settings": [
  {
    "Filter": "",
    "Name": "encryption-module",
    "Value": "aes",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "compression-module",
    "Value": "zip",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "dblock-size",
    "Value": "1GB",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "keep-time",
    "Value": "1M",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "passphrase",
    "Value": "OBFUSCATED",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-mail-any-operation",
    "Value": "true",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-mail-body",
    "Value": "%OPERATIONNAME% is %RESULT%",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-mail-level",
    "Value": "all",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-mail-password",
    "Value": "SMTP securise pour OBFUSCATED.",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-mail-subject",
    "Value": "Duplicati %OPERATIONNAME% report for %backup-name%",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-mail-to",
    "Value": "OBFUSCATED",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-mail-url",
    "Value": "smtps://ssl0.ovh.net:465",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-mail-username",
    "Value": "OBFUSCATED",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--dry-run",
    "Value": "false",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-http-any-operation",
    "Value": "true",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-http-extra-parameters",
    "Value": "client_slug=OBFUSCATED",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-http-level",
    "Value": "all",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-http-message",
    "Value": "Duplicati %OPERATIONNAME% report for %backup-name%\r\n\r\n%RESULT%",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-http-message-parameter-name",
    "Value": "message",
    "Argument": null
  },
  {
    "Filter": "",
    "Name": "--send-http-url",
    "Value": "https://OBFUSCATED/d/report",
    "Argument": null
  }
],
"Filters": [],
"Metadata": {
  "LastErrorDate": "20171122T180018Z",
  "LastErrorMessage": "Found 1 files that are missing from the remote storage, please run repair",
  "LastDuration": "02:22:53.4306641",
  "LastStarted": "20171207T180000Z",
  "LastFinished": "20171207T202253Z",
  "LastBackupDate": "20171207T180000Z",
  "BackupListCount": "25",
  "TotalQuotaSpace": "0",
  "FreeQuotaSpace": "0",
  "AssignedQuotaSpace": "-1",
  "TargetFilesSize": "604188927686",
  "TargetFilesCount": "1198",
  "TargetSizeString": "562,69 GB",
  "SourceFilesSize": "889188370952",
  "SourceFilesCount": "380674",
  "SourceSizeString": "828,12 GB",
  "LastBackupStarted": "20171207T180000Z",
  "LastBackupFinished": "20171207T202253Z"
},
"IsTemporary": false
  },
  "DisplayNames": {
"C:\\Libel\\": "Libel",
"\\\\atrisme\\candidatures\\": "candidatures",
"\\\\atrisme\\projets\\": "projets",
"\\\\atrisme\\outils\\": "outils",
"\\\\atrisme\\direction\\": "direction"
  }
}

#2

I guess you mean that the list of storage providers is empty in the Web UI. Is this correct?

I once had these symptoms. Try this:

  • Restart your computer. May sound silly, but sometimes I can’s find any active Duplicati related process, but something in memory seems to remain active.
  • If this doesn’t help, stop all active Duplicati instances, preferably unregister the Duplicati service when running as a service, download the Zip version of Duplicati (the same version as you are using now) and copy the contents over your current program folder. Then (if applicable) register the service and start your Duplicati instance.

#3

Hi,

You’re right, the list of storage providers is empty.

And IT Crowd - Have You Tried Turning It Off And On Again?

It actually works!

Thank you and sorry for time loss.


#4

I encountered the same problem using the official Docker container version 2.0.3.3_beta_2018-04-02. Restarting the container did the trick.