Status is stuck at "Waiting for upload" stage

Hi guys,
I have a question about the status message at the top of the screen (I’m using Duplicati running on Windows 10, as a service).
I had various issues with my largest backup (the total size is around 10gb), with backups failing, repairs/deletes not helping, and so I decided to create a new backup job, in place of the old one.

All fine and dandy, except now that it’s finished doing its’ local stuff, it is apparently “waiting for upload”. It’s been like this for about 2 hours, and my internet is working fine, so I’m not sure what it’s waiting for.
I’ve never seen this message before, any ideas? Or should I just leave it alone overnight?

Thanks a lot

If you have a lot of files making up that 10G of source data, you might be experiencing the “final file” upload issue mentioned here:

Though two hours is pretty long…

If you go to the “Processes” tab of Task Manager (ctrl+shift+escape) and find the “Duplicati.Server” row, is there any activity in the Network column?

Alternatively, you could go to the “Performance” tab, click the “Open Resource Monitor” link (near the bottom), and check out the Network tab in the Resource Monitor window.

I’m not sure what should be showing in the Duplicati logs during this step, but you could also check the main main “Show Log” page and select the “Live” button then the “Profiling” option to see what the most recent commands were.

Did you by any chance increase the upload volume size (step 5 in the wizard, default 50 MB) to an extremely large value?
If you changed it to a value larger than 10 GB, your complete backup is in a huge single zip file, uploading it can take a while.
If this is the case, you might consider re-configure your backup and start over, because restoring a single file will require downloading that huge zip file.

Thanks for the tip - I have broken this backup into 4 smaller ones, and left the 50MB default as-is. Running again now, so let’s see what happens.

Thanks very much.

Same here…everything was working perfectly and suddenly after couple weeks I run into same issue: “Waiting for upload to finish…” and gets stuck. After machine reboot - same situation again.
Total size of the backup: 2gb. Encrypted files size: 50mb each. Destination: Google Drive

What files are getting on Google Drive? Ordinarily I’d expect a 50MB dblock then its much smaller dindex. Repeat those pairs, then end with a dlist. You can see files go out in About --> Show log --> Live -> Retry Increasing Retry to Profiling will also give clues as to where it ends. Do you get new backups in Restore?

I’m having the same issue on a fresh install of the latest canary on my Raspberry Pi, I created a separate thread about it here: New backup to Wasabi stuck at "Waiting for upload to finish ..."

Are you using email to send a notification of the job? I just discovered that STARTTLS was the cause and disabling it for this one machine has solved the problem - updated details on my thread.

1 Like

This helped - thanks a lot for this hint!