SSH with key authentication failing


I’ve setup ssh access to my server with key authenitcation, and tested it from the terminal, and it works.
I then tried to setup a Duplicati backup using ssh with key authentication.
The key was generated with

ssh-keygen -t rsa

(because RSA is the only format supported by Duplicati, if I understood correctly)
What I put in the required fields is:

  • Username: the ssh user;
  • Password: the passphrase for the ssh key;

then I added the advanced option “ssh-keyfile”, and filled its field with the path to the key file.
The file is found correctly, however I keep getting the error
"Failed to connect: Failed to parse the keyfile, check the key format and passphrase. Error message was Key ‘OPENSSH’ is not supported."

Searching on the forum I wasn’t able to find anything useful (apart from the fact that the key must be an RSA one).

A thing that makes me wonder are the words in the description of the advaced option:
"[…] This option only works when using the managed SSH client."
What does that mean? Am I using the managed SSH client? I’m using the .deb package downloaded from the duplicati website, installed in a Debian Stretch chroot on a Debian Testing host.

Please ask me any other useful information that you need and I’ll give them you as soon as possible.



It sounds like your key is using the new OPENSSH format, which Duplicati doesn’t support yet. Can you try the suggestion here to create a key with the old format?

ssh-keygen -m PEM -t rsa -b 4096


Thank you very much for your ultra-fast answer, it worked like a charm! This was my first question on this forum and I have to say that the support for Duplicati is outstanding!