SSH connection works, but backup fails

I am new to Duplicati so please be a little patient.

I tried setting up Duplicati so it uses a SSH connection to my Ubuntu server. When I hit “test connection” it says connected successfully", however, when I run a Backup job this fails. The logfile says this:

—> System.AggregateException: Permission denied —> Renci.SshNet.Common.SftpPermissionDeniedException: Permission denied

bei CoCoL.AutomationExtensions.d__10`1.MoveNext()

Can you please tell me what I am doing wrong?


Welcome to the forum @Giorgios

Have you tried a file upload with a different SFTP client such as WinSCP, Cyberduck, Linux sftp, etc.?
You should use whatever login credentials you’re using with Duplicati. Perhaps that login only allows a directory listing (which is what a Test does – it’s just basic connectivity), but denies ability to write files.

The failed operation can be seen in more detail with About → Show log → Live → Retry during backup.

Is there anything logged on the Ubuntu side? I would suggest trying this:

egrep “fail” /var/log/auth.log

This should return among other things failed SSH logins and might shed some light on the reason.