# \[Solved\] Minio, NGINX, SSL Issue

**URL:** https://forum.duplicati.com/t/solved-minio-nginx-ssl-issue/4223
**Category:** Support
**Created:** [July 27, 2018, 4:33pm UTC](https://forum.duplicati.com/t/solved-minio-nginx-ssl-issue/4223 "2018-07-27T16:33:18Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![johnross2007](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/dfb087/32.png) [@johnross2007](https://forum.duplicati.com/u/johnross2007)
#### Post date: [July 27, 2018, 4:33pm UTC](https://forum.duplicati.com/t/solved-minio-nginx-ssl-issue/4223/1 "2018-07-27T16:33:18Z")

</div>

I’m having trouble getting Duplicati to reach my Minio server. I set up an NGINX reverse proxy VM which forwards to the minio VM. I set up Let’s Encrypt on NGINX. I can access Minio through the appropriate subdomain using HTTPS in the web browser.

However, Duplicati throws up two different error messages, depending on how I type in the URL. If I use “url.url”, I get “Failed to connect: The request signature we calculated does not match the signature you provided. Check your key and signing method.” This happens whether or not s3-ext-forcepathstyle or “use-ssl” are selected.

If I instead use “[https://url.url](https://url.url)”, I get Failed to connect: A WebException with status NameResolutionFailure was thrown.” This happens whether or not s3-ext-forcepathstyle or “use-ssl” are selected.

---

<div class="post-metadata">

### Author: ![ts678](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/t/8491ac/32.png) [@ts678](https://forum.duplicati.com/u/ts678)
#### Post date: [July 27, 2018, 6:52pm UTC](https://forum.duplicati.com/t/solved-minio-nginx-ssl-issue/4223/2 "2018-07-27T18:52:11Z")

</div>

Welcome to the forum @johnross2007

If nobody here has an answer, you might try putting that error message in a search engine for some ideas (although some people have found that path difficult too). It probably comes from third-party library code.

Although I don’t have anything that talks S3, I did use the Duplicati GUI to play with naming, then went into Commandline in the GUI to see what had been made. Here are examples from a predefined server and a custom one, putting url.url in the customer server entry field.

s3://myaccessid-mybucket/?[s3-server-name=s3.amazonaws.com](http://s3-server-name=s3.amazonaws.com)&s3-location-constraint=&s3-storage-class=&auth-username=myaccessid&auth-password=mykey

s3://myaccessid-mybucket/?s3-server-name=url.url&s3-location-constraint=&s3-storage-class=&auth-username=myaccessid&auth-password=mykey

---

<div class="post-metadata">

### Author: ![johnross2007](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/dfb087/32.png) [@johnross2007](https://forum.duplicati.com/u/johnross2007)
#### Post date: [July 27, 2018, 8:38pm UTC](https://forum.duplicati.com/t/solved-minio-nginx-ssl-issue/4223/3 "2018-07-27T20:38:59Z")

</div>

Thanks! I just fixed it. Doing a backup now but it looks like its working fine.

I had not accurately followed the directions at: [Minio Docs for NGINX Setup](https://docs.minio.io/docs/setup-nginx-proxy-with-minio)

However, including the “health\_check” from that link broke NGINX. After deleting that, everything works.

I don’t understand exactly what proxy\_set\_header does, but its addition is what fixed my issue.

---

<div class="post-metadata">

### Author: ![justsomeuser](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/e95f7d/32.png) [@justsomeuser](https://forum.duplicati.com/u/justsomeuser)
#### Post date: [March 9, 2019, 4:36pm UTC](https://forum.duplicati.com/t/solved-minio-nginx-ssl-issue/4223/4 "2019-03-09T16:36:15Z")

</div>

For those potentially looking for more detail, the active health check with “health\_check” is only supported by paid commercial nginx installations, which is likely why it was failing.
