Smart Backup option not being saved in 2.0.2.17_canary_2018-01-23


#1

I am currently running 2.0.2.17_canary_2018-01-23 and trying to set the “Smart Backup” option. Unfortunately, after I select “Smart backup retention” and save the configuration, when I go back and edit the job it reverts back to “Delete backups that are older than 3 months.” Is there something else I need to set to enable smart backups?


#2

Just upgraded to 2.0.2.19_canary_2018-02-12 and still having the same problem.


#3

Not tried it myself, but setting it to “keep all backups” first, then saving the backup job, edit the job again and change it to smart/custom backup retention seems to help.


#4

Just tried that solution, but no go. All other options seem to stay between edits, but “Smart Backup” just won’t stick. I’m going to try a full uninstall/install to see if that helps. I’ll let you know…


#5

No joy :frowning: Tried uninstall and reinstalling duplicati-2.0.2.19_canary_2018-02-12-x64 and Smart Backup still won’t save as an option.


#6

Had a similar problem with trying to save with “Custom backup retention”

It finally took by setting it to keep all backups then going back in and setting it to custom.

Does anyone know if the custom backup replaces the current retention policy advanced option?