Slow local network and cloud backup

#1

Hello
I have noticed that after a certain time the backup is slow, this is in version 2.0.3.6.
I have local backups and in B2 on different networks and servers, the behavior is the same.
Informs that he is running but the progress bar nothing happens.

0 Likes

#2

I also noticed Duplicati being very slow in subsequent backups to both local and cloud locations. My test backups performed great but now my real backups are in the 200-500 GB range. Even with minimally modified files (500-1000 MB), backups take anywhere from 45 min to 2 hours to complete.
I am using the latest beta version and default settings. This makes it very hard to use Duplicati as a serious backup solutions, in particular it doesn’t even wake up the computer so you cannot run those backups at night easily.
What is the bottleneck here?

0 Likes

#3

Hello
The backup run time has lasted many, even after minor modifications to the files.

I believe this will be corrected in the next version.

0 Likes

#4

I noticed that Duplicati on a Mac is using (if everything runs normally and Duplicati is not acting up weirdly) less than 1% CPU. I wonder if this is a bottleneck? Crashplan has an option to decide how much CPU sources to allocate while the computer is being used versus the user being away. If Duplicati could use more system resources while no-one is using the computer this might help.

0 Likes

#5

Unfortunately, at present Duplicati doesn’t have a “be more aggressive if computer is not in use” feature, just the static --use-background-io-priority and --thread-priority advanced parameters.

--use-background-io-priority
This option instructions the operating system to set the current process to use the lowest IO priority level, which can make operations run slower but will interfere less with other operations running at the same time
Default value: “false”

--thread-priority
Selects another thread priority for the process. Use this to set Duplicati to be more or less CPU intensive.
Default value: “normal”


You may be running into the general 2.0.3.6 performance issue mentioned here:

I’m not sure how long until the fix will be made available, but if you can’t wait you might want to consider downgrading to 2.0.3.5 (or older) as described here:

0 Likes