Sia - Failed to connect: Input string was not in a correct format

Hi, I have been following the instructions at

I’m on and have also tested the previous 3 versions.
All give me same error when testing the connection: Failed to connect: Input string was not in a correct format.

My sia-UI is v 1.3.2 (also tested on 1.3.1).
I have 94 contracts and wallet is unlocked.

Any suggestions?

Hi @nix, welcome to the forum! (And sorry for taking so long to get back to you.)

This sounds like more of a parameter formatting issue than a problem with SIA. Can you use the Duplicati job menu to “Export as Command-line” and paste it here (with any person stuff like passwords and email addresses removed) so we can check for possible formatting problems?

Thanks, here’s the export:

"C:\Program Files\Duplicati 2\Duplicati.CommandLine.exe" backup "sia://" "D:\Duplicati\\" --backup-name=sia --dbpath="C:\Users\root\AppData\Local\Duplicati\UVDZUZFAVM.sqlite" --encryption-module= --compression-module=zip --dblock-size=2GB --no-encryption=true --disable-module=console-password-input

In the Duplicati config for the Sia backup job, instead of filling in “”, try just “localhost” (with no port specified). This is what I had to do to get mine working. My exported config therefore ends up looking similar to yours with a subtle difference:

“C:\Program Files\Duplicati 2\Duplicati.CommandLine.exe” backup

Also I think you should make your dblock size something smaller than 2GB for Sia. In early tests I did on Sia backups I found that sia transfers could fail fairly often and cause duplicati to hang and become confused; my more recent tests went a lot better and I had no issues with 500MB dblocks, but even those are probably on the high end of what I’d advise (to be safe I’d honestly recommend around 100 - 200 MB).

Thanks! I’ll look into the size issue when I get there.
I tested:
Both give the same error: “Input string was not in a correct format.”

Is it supposed to be “sia://localhost//backupfolder” and not “sia://localhost/backupfolder” with a single slash after localhost?

I don’t know much about Sia, but I don’t think it’s a valid url with two tracing slashes.

My (working) Sia backup job, when exported to command line, populates with 2 forward slashes like this as well, so i’m guessing it’s not an accident (the GUI configuration doesn’t even let you touch these of course).

Can you post a screenshot of what your configuration looks like in the Duplicati UI?


Mine is all the same except for the “server” field I simply have “localhost” (as i mentioned before) - you said you’ve already tried it that way too?


Weirdly, even if I type something wrong in “Server”, I can’t reproduce the error message you’re getting. Can you also try creating a brand new backup job (just as a test), set all the same options, and try it again?

Same issue here. I’m on Macos Sierra though and am facing the same problem and error message, whether I try or localhost…

Hi @lorenzolamasse, welcome to the forum!

Do you recall what version of Duplicati you are using?

Also, did you look in the global logs for any error specifics as suggested here?

I’m having the same issue. Any solution? I’m on the latest stable release and Windows 10.

Hi @bjorn, welcome to the forum!

When you say the latest stable version, do you mean beta?

Also, can you post the write message text from the logs?

Duplicati -

I don’t have the SIA implementation running currently.