Semi-Annual Google Oauth failure [solved]


#1

Three of my six monthly backups ran on 1 Feb 2019. Now they all fail when I test connection. Is this Google changing the rules again and I just need to wait for Duplicati to catch up? same thing happened in March 2018. I did a lot of flapping around and it eventually started work, and I’m pretty sure it was NOT because of anything I did.

Duplicati 2.0.2.1
Linux Mint 18.3

Failed to connect: Failed to authorize using the OAuth service: GetResponse timed out. If the problem persists, try generating a new authid token from: Duplicati OAuth Handler


#2

Restarted duplicati today and Oauth worked, just like the last time.


#3

Interesting. Do you have extremely long uptime for your system and Duplicati? On Windows, Microsoft tends to force updates in, so I don’t get to find out whether there are any issues there from long-running Duplicati…

Sometimes mono or its trusted certificate store can cause connection issues (which yours may have been). Regardless, I’m glad you found a way to get things going again even if we never track down the exact cause.


#4

If by extremely long you mean days to a week or two, yes. Something
makes me restart the computer at least a couple times a month.