Scheduled jobs not running with Windows Service

I have installed Duplicati - I installed the Windows service. I have scheduled jobs, and verified that the windows service is running, however, the scheduled jobs do not run - they will only run interactively when I launch the GUI. How can I create a job with the GUI but be executed by the running service?

Hi @bbarendt, welcome to the forum!

Are you using the Tray-Icon to open the Duplicati GUI? If so, I suspect you are bumping into the issue where the service is running on port 8200 but the tray icon is opening the GUI on port 8300.

If that’s the case, then the problem is likely that your jobs were created and scheduled on port 8300 which only runs when the tray icon is running.

Can you double check what port number is in use when you see your jobs listed?

netstat -ano shows have listeners on both 8200 and 8300 - I suspect that the 8200 is in fact the service and the 6 processes listening on 8300 are my jobs. How do I change them to 8200 so that the service can run the schedule?

I figured it out. I exported the jobs from the browser running on port 8300, re-launched the browser to port 8200 and imported the jobs. Thanks for the help.

You’re welcome - sorry you had to figure out the export thing on your own, stupid real life keeps dragging me away from the fun stuff like helping out here!

In case you haven’t done it yet, you might want to rename (or delete) the jobs on the 8300 port GUI to make it clear they’re NOT the ones you want to be using.

If you haven’t done so already and you want to keep using the tray-icon, try adding the --no-hosted-server parameter to the “Duplicati.GUI.TrayIcon.exe” shortcut. This will tell Duplicati to use the existing server at 8200 instead of starting it’s own at 8300.

(Oh, and I flagged your post as the solution - please let me know if you disagree.)