Restore on duplicati 1.3.4 failes with "Invalid filename detected"

A relative of me is using duplicati 1.3.4 since years to store to a remote SSH storage, due to the slow internet line, the last full backup was done in 2016, since then all backups were incremental.
Recently her SSD failed. I replaced the SSD, installed Windows 7 and duplicati, recovered the backup settings and tried to do a restore.
Unfortunately, the restore on Windows failed, and only Files from the last full backup were restored (it is unclear if all files from that backup were restored, I wasn’t there when the backup finished).
I tried to restore the files on my linux computer, using a local copy of the backup archive. Unfortunately, the restore failed with a message saying:
"The restore operation failed: Invalid filename detected:
[some filenames] error message:
Input string was not in correct format:

I thought I could get around this by only restoring a subset of the files, but this failed when trying to list the content of the backup:

Any advice how to recover from this problem and get as much files back as possible? I have both Linux (Debian) and Windows 7 at hand to further investigate.
Unfortunately, I didn’t find to much documentation about duplicati 1.3.4, if i missed something, I would be glad to get a link to it.

This forum is pretty much all Duplcati 2 related, so there aren’t many people here with Duplicati 1 experience. While there are a few, sadly I’m not one of them so I can’t help much but some of the others may see your post and be able to help.

I realized that Linux may not be the best OS to restore a windows backup and have continued my restore attempts on a Windows systems with a local copy of the backup archive.
I ended up with a message about checksum mismatch in an incremental backup file. I compared checksums of the corrupt file with the one stored on the backup server, they were the same. To circumvent this problem, I enabled the options “skip-file-hash-checks” and “dont-read-manifests”.
Unfortunately, this failed too with error Message “Message has been altered, do not trust content”:

Any ideas how to recover from this?

Regarding duplicati v1, this is pretty much it:

That said, you might be lucky and find someone here with v1 experience…

I was aware of the fact that development of version 1.3.4 has stopped. On the other side, using beta software for backup unfortunately also doesn’t sound like a good idea.
After this disaster is cleaned up, I will need to put some time into finding a good alternative which is both reliable and able to do backup over slow uplinks.

1 Like