Restore on another machine

I’m trying to restore my windows files on my linux machine.
I choose Direct restore from backup files. I choose Google Drive and the path duplicati-windows and write the AuthID. However Duplicati says the directory does not exist, create it now?. This is familiar from the backup process where duplicati has access only to the directories it has created. But now I am restoring files and creating a new directory does not help. What to do?

On Windows I use the drive letter G:. On Linux I have to use Google-Drive support. This may make things a bit difficult.

This sounds like on Windows you never let Google Drive know Duplicati made its files.

Can you go to, pick a file, and use the information screen? Who created the file?


would be the desired creator, and is what happens when you set Storage Type to Google Drive.

If the files do not show created by Duplicati, fast but maybe not long-lived (Google wants to stop it) workaround is for Linux to get an AuthID from Duplicati OAuth Handler that lets it see all of the files:


Last I looked, Google Drive provided no way to change the creator of record, but you can painfully reupload all of the backup files with Duplicati.CommandLine.BackendTool.exe plus some scripting.

Thank you, it takes me time to go through your answers.

It works fine if you use Google Drive, path duplicati-windows on Windows, not G:\My Drive\duplicati-windows.
Then in Linux one can use the AuthID created in Windows and one can restore Windows files. There was a small bug, at least in Finnish version of duplicati, step 4. Restore Settings was missing and it appeared under step 2.