Restore fails with Found 12821 parse-able files with the prefix

Hello, I am backing up 2 windows servers with Duplicati, backups are encrypted and stored on S3.

we suffered a Ransomware attack overnight and I want to restore from a previous backup, however when I do a “Direct Restore from Backups Files” I get the following error…

Found 12821 parse-able files with the prefix New duplicati/duplicati, did you forget to set the backup prefix?

I have tried adding --prefix=“New duplicati/duplicati” and --prefix=New duplicati/duplicati to advanced settings in the restore options but I continue to get the same error.

Any suggestions.

Thanks in Advanced.


Strange, I’m not sure how you have a slash in your prefix. Maybe that is allowed with an S3 target.

But before we dig into that, is the system that did backups using Duplicati still functional with an in-tact job database? If so you can avoid doing “Direct restore from backup files” and just use the quicker restore option from the job definition itself.

If it’s not functional, then we’ll need to figure out this prefix thing. Any chance you can take a screen shot of what some of the filenames look like in this S3 bucket?


Thanks for your help. No the system is not functional, despite having AV software the Ransomware encrypted the files.

Here is a look at the file structure in the S3 Bucket…



Looks like you aren’t actually using a custom prefix. The default is “duplicati” so files start with “duplicati-”.

Maybe what happened is you didn’t enter the folder path and left it blank?

yep that’s what it was! Thanks for that, I am currently doing the restore now, it is of course taking ages, this is it about 12 hours in (from AWS)…

OTTOMH I’m restoring a few 1000 files to about 200GB, At what stage do I call it failed and retry?


This database recreation phase can take a long time under certain circumstances. If you open a new tab and check About → Show Log → Live → and set the dropdown to Verbose you might get a better idea about where it is… it should say “processing X of Y” or something to that effect (where X and Y are numbers).

Note that “direct restore from backup files” has a downside - this database recreation is temporary. You may have been better off creating a new backup job and recreating the database that way as it would be retained so you can more readily do multiple restores.

Thanks HEAPS!, this is awesome info, I’ve always wanted to know how to see what was happening behind the running task! :slight_smile: