Release: (beta) 2020-01-18

This beta release is a collection of additions and improvements from many contributors.
Since it is released more than a year after the last beta, there is a large number of changes.

Important notes:

  • On Linux, macOS, and other systems that require Mono, this version requires Mono v5 or later.

  • On macOS please remove the current beta and install this version, instead of using the updater. Doing so, will make Duplicati compatible with Gatekeeper and allow you to grant permissions.

A big thanks to all Duplicati contributors, supporters, fans and users for keeping the project evolving and improving.

Note that the beta v2.0.4.23 has database version 8 and this release has database version 10. This means that your local database will be upgraded once you run this version, and you cannot roll back without some manual intervention.

Here is a short list of some of the more notable changes:

  • Numerous bug fixes and performance enhancements.
  • Updated translations, new languages added.
  • Improved support for macOS Catalina
  • Add support for minio backend.
  • Improve tray icon to reflect warning state.
  • Fix long path issue when path has 259 or 260 characters.
  • Remove support for Amazon Cloud Drive.
  • Fix input issues with dark theme.
  • Fix bug in handling filter expressions.
  • Fix purge operation with simple filters and case-sensitive filesystems.
  • Fix ignoring of --tempdir option when using the command-line.
  • Improved list of S3 compatible options and providers.
  • Fix ability to stop backup after current file has finished processing.
  • Updates to support libraries
  • Improve logging during database recreation.
  • Add option to skip vacuum operations within specified duration, --auto-vacuum-interval.
  • Add option to skip compact operations within specified duration, --auto-compact-interval.
  • Fix backup corruption from upload throttling. #3787
  • Fix for “Unexpected difference in fileset”. #3800
  • Fix for “CheckingErrorsForIssue1400” and “FoundIssue1400Error”. #3868
  • Fix for “FTP (Alternative)” upload verification.
  • Server database version is still 6. Backup database rose to 10. This may impede downgrades.

Congrats on another beta! When you say “remove the current beta” on MacOS, does that just mean dragging to the trash can or is there an uninstaller somewhere?

Dragging it to trash will work. You can also just drag the new version in, and overwrite the existing version.

The important part is to not use the built-in updater, as that will leave you with the old launcher, which does not work well with Gatekeeper.

1 Like

Congratulations on a much-anticipated release! Upgraded 6 machines today (Windows 10 & Debian 9) with only minor issues (that I actually don’t think are related to the upgrade). Will be trying a MacOS upgrade tomorrow.

Well done, everyone! :slight_smile: :clap:



Thank you for a long awaited release!
I will be trying it out in the coming days.

Would it be a good idea to post an announcement or make this post an announcement (not sure if a post can have multiple categories), so that it shows in the “News” section on the main web site?

Upgrade Windows 7 system yesterday no issues. Great work in getting this out

Will be doing several Centos and Windows Servers over the coming days.

Duplicati fails to install at Centos 8 #3950 shows how EPEL 8 lacks a needed Duplicati dependency, possibly related to the indicators transition where Ayatana Indicators hopes to be the future direction.

Or it could just be a package personnel and new OS version package priority thing. I just don’t know. Anybody with a good guess of the future Red Hat direction is invited to update GitHub issue above…

1 Like

After installing this version on macOS 10.14.6 with Mono (multiple computers) I see the following error in my output log:

Failed to load process type Duplicati.Library.Common.IO.VssBackupComponents assembly /Applications/
, error message: Could not load type of field ‘Duplicati.Library.Common.IO.VssBackupComponents:_vssBackupComponents’ (1) due to: Could not load file or asse
mbly ‘AlphaVSS.Common, Version=, Culture=neutral, PublicKeyToken=959d3993561034e3’ or one of its dependencies. => Could not load type of field ‘Dupli
cati.Library.Common.IO.VssBackupComponents:_vssBackupComponents’ (1) due to: Could not load file or assembly ‘AlphaVSS.Common, Version=, Culture=neut
ral, PublicKeyToken=959d3993561034e3’ or one of its dependencies.

Backup continues normally and completes successfully. I only call Duplicati from the command line, so I’m not sure if others who use the GUI will/have seen this error.

Hi, I am currently running X64 with no problems.
Can you recommend upgrading to 2020-01-18X64 and if yes, are there any
topics to take care of before/during the upgrade.
(Of cource I will backup the existing duplicate core database).

Technically the codebase is identical among,, and

You can certainly upgrade to beta if you want to get back on the generally more stable beta channel, but there will be no functional differences.

1 Like

Settings can change you to Beta channel if you like. It would avoid future Canary that are less stable. While Canary testers are very valuable, there’s some risk to Canary because it’s a very early release.

Release: (canary) 2020-01-18 is a case in point. Somehow it’s broken, and waiting for a fix.
Beta is not perfect but at least got more testing behind it as it went through Canary and Experimental.

1 Like

In case this helps anyone, when I upgraded my Duplicati on Ubuntu 16.04 from the UI (download, then activate), I couldn’t access the UI anymore. I had to issue “service duplicati restart” in a terminal to get things running again. I’m not sure if I did something wrong or if that’s a required step but it seems that’s all it took.

Thx for the Update. I have problem installing it on a Win Server 2016. I got the following error:

`System.UnauthorizedAccessException: Der Zugriff auf den Pfad “agsXMPP.dll” wurde verweigert.

  • bei System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive, Boolean throwOnTopLevelDirectoryNotFound, WIN32_FIND_DATA& data)*

  • bei System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive, Boolean checkHost)*

  • bei Duplicati.Library.AutoUpdater.UpdaterManager.DownloadAndUnpackUpdate(UpdateInfo version, Action1 progress)*

I am using: as service
Any suggestions?

It looks like the autoupdater is attempting to delete old versions of Duplicati. However, something prevents it from deleting (at least) the file agsXMPP.dll from the update folder.

A quick-fix is to re-install from the MSI.

If you would like the autoupdate feature to work, then you need to check permissions on the update folder (located under application settings for the user running the service).

1 Like

I am getting the same error message on all my Mac computers running High Sierra or El Capitan and using the GUI. I have installed and Mono The error does not happen every time, sometimes it runs several backups with no problems. I checked the dmg of Duplicati under Resources and there are no AlphaVSS related files and no such files exists on my computer.
I checked an old backup version for Duplicati and found those AlphaVSS files being installed under Library>Application Support>Duplicati in a version-specific Duplicati “updates” folder. The latest version of Duplicati did not install those files.
I also believe I have one computer running Duplicati for more than a year now with no error messages and cannot find AlphaVSS files on this installation at all.
So why do some Mac computers have those files installed but not others, and why are some Duplicati installs complaining about not being able to load the file, but not for every backup.
What is going on here?

Thank you. I was able to solve it using the console. With the next Update i got new problemes and solved it with a new installation.