Release: (canary) 2018-12-29

  • Improved passphrase export, thanks @Pectojin
  • Fixed an issue with restores that have no password, thanks @warwickmm
  • Fixed a process shutdown/restart issue on Synology, thanks @drwtsn32x
  • Improved build and tests, thanks @verhoek
  • Fixed issues with displaying logs from the UI, thanks @Pectojin
  • Improved performance of filters by around 10x, thanks @warwickmm
1 Like

Nice work, but i must updating this version manually

see also previous versions, for example

Dec 29, 2018 10:17 AM: Error in updater
System.IO.InvalidDataException: Unable to verify signature
   bei Duplicati.Library.AutoUpdater.SignatureReadingStream..ctor(Stream stream, RSACryptoServiceProvider key)
   bei Duplicati.Library.AutoUpdater.UpdaterManager.CheckForUpdate(ReleaseType channel)
Dec 29, 2018 10:17 AM: Error in updater
System.Net.WebException: Der Remotename konnte nicht aufgelöst werden: ''
   bei System.Net.WebClient.DownloadFile(Uri address, String fileName)
   bei Duplicati.Library.AutoUpdater.UpdaterManager.CheckForUpdate(ReleaseType channel)

Confirmed, same identical mistake.

Yeah, same signature problem.
After debugging it really problem on server side
Because manifest files from is parsed successfully but its clearly different from manifest downloaded from server - in signature.

This function is OK for manifest from github and FAILS for manifest downloaded.

One more observation - don’t know if it could have impact, one file is on drive 2x bigger than another - same content. Probably coding file in Unicode issue - it could affect stream.

Hi, i like this new screen logging, just a couple of notes:
1 - Is the box with the “?” right that it is always at “0”? Even previous backups always give me “0”;
2 - Can you also have the total size of the space used? This entry, for instance: “KnownFileSize”: 33009874853, maybe instead of the previous 3 entries if you don’t need.

Arh! That got me on track! It is a problem with the mirror. It detects a new version and downloads that, but overwrites the old file without truncating it first. Normally that is not a problem because the manifest file grows in size. But I recently removed a bunch of old release notes, so the new file is smaller, causing the downloaded file to contain junk at the end.

I have fixed the mirror server and now it serves the correct file.


Nice thx, now it detect and download update. :+1:

Still fail to activate — Activate downloaded upgrade sometimes fail — at least once per month with Windows updates system restart activate new version of Duplicati :slight_smile:

Yeah it fails to update for me as well. It stops the service and then nothing. Have to restart it and then it doesn’t update - fails back to what it was before,

The auto-update finally works for me again; installation worked as normal (the new version installed correctly but I still needed to manually re-launch duplicati in Windows, which is how it has always behaved on this PC).

Same here on a Mac (though by re-launch I would mean re-boot).

My Docker container updated & restarted just fine. I’m assuming the notification of the new version was left over from before the update???

I have had one or two times where a bad download (or decompress) caused the update to fail. It’s been a while but I think I ended up having to delete the “offending” version from the “updates” folder and just try the update again at which point it worked.

I think I’ve seen persisted notifications before. I forget whether it was every time. This time, I tested getting a fresh notification just like yours, and saw a new row in the Duplicati-server.sqlite server database containing

“1” “Information” “Found update” “” “” “update:new” “1546449496” “NewUpdateFound”

Duplicat restart with no Internet connection popped that right up again, but pressing Dismiss deleted DB row.

… to add onto this… Manjaro package manager notified me of the same .10 update that Duplicati told me about a few days prior. Ran that install and all worked. Not sure why the updater has or had issues within itself to update but running the update package released in the AUR fixed it.

Yes, that is my guess. The updater triggers a notification right before shutting down. When it relaunches in the updated version, it shows the notification, even though the information is no longer relevant.

1 Like