Raspberry pi Docker image?

Hi I’m running Docker on my raspberry pi, and I love the concept of isolated applications, but I found no official Docker image for arm32v6 or 7, has any one managed to create one?

If so could you share the Docker file?

I tried to create one my self and tried to base it on Debian 7 -to 9, but had problems no matter what I tried.

Either I had problems installing mono or installing the Deb file (some missing requirements).

Wow - I didn’t know a Raspbery Pi could run Docker or mono. :slight_smile:

I take it nothing from the Docker Hub worked for you?

The only thing I found on docker hub gave exec error and that means the image is for the wrong platform.

But yes there is a Linux distribution that is made for Docker on raspberry pi, http://blog.hypriot.com I’m running on a pi 3 but it works great so far.

I’m only a few months into Docker myself so thanks for helping me learn something new!

Unfortunately my Pi is a first gen so I don’t think I’ll be able to help much, but I look forward to hearing that somebody has gotten it working!

Mono should be really simple to set up:

Once you have that, simply use the Duplicati zip and run:

mono Duplicati.CommandLine.exe

AnderssonPeter, I’m not up-to-date with the ARM side of things so this could be totally off-base but is what you’re working on at all similar to this, except in a Docker container?

i get the following error when i try to install deb package

Selecting previously unselected package duplicati.
(Reading database ... 15377 files and directories currently installed.)
Preparing to unpack duplicati_2.0.2.1-1_all.deb ...
Unpacking duplicati ( ...
dpkg: dependency problems prevent configuration of duplicati:
 duplicati depends on libmono-2.0-1; however:
  Package libmono-2.0-1 is not installed.
 duplicati depends on libappindicator0.1-cil | libappindicator3-0.1-cil; however:
  Package libappindicator0.1-cil is not installed.
  Package libappindicator3-0.1-cil is not installed.
 duplicati depends on gtk-sharp2; however:
  Package gtk-sharp2 is not installed.

dpkg: error processing package duplicati (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

any idea what is wrong?

I believe it is telling you that you need to install the packages: libmono-2.0.1, libappindicator0.1-cil and gtk-sharp2.

The libmono dependency suggest that you have not installed Mono:

I installed mono by following the Debian 9 example and then running apt-get install mono-devel.

Ok, maybe there is another reason that libmono is missing.

Anyway, dpkg does not automatically install the depending packages like apt-get does. This page suggests using sudo apt-get -f install duplicati.deb:

Thanks for the tip but that still gave some errors, but the following worked (found in the thread you posted):

dpkg -i duplicati_2.0.2.1-1_all.deb
apt-get -f install
dpkg -i duplicati_2.0.2.1-1_all.deb

BTW: A good way of showing your appreciation for a post is to like it: just press the :heart: button under the post.

If you asked the original question, you can also mark an answer as the accepted answer which solved your problem using the tick-box button you see under each reply.

All of this also helps the forum software distinguish interesting from less interesting posts when compiling summary emails.

This post is a littlebit older but I have an answer that may be of interest for you.
Because I also wanted to let Duplicati run on an ARM computer (in my case odroid XU4), and all my services are already Docker containers, I built a Docker Image for Duplicati that works on the arm32v7 plattform.

It can be just pulled from dockerhub, or built from git source. I also added examples for docker-compose: