Problems with the dbase backup

Hi guys, I continue every time I try to restore the backup dbase me by mistake and then I can not backup.
I have to delete the database every time and then redo the backup from the beginning.
I hope you find a better solution to restore the backup dbase, I can not every time I try to restore the dbase I get all these errors

Sorry, I’m not following what’s going on. How is a mistake involved, and is this a restore as in a normal file restore (followed by inserting the database), or are you doing a Recreate as seen on the Database page? There’s also a Delete button there. Are you saying Recreate is giving you errors? Do you have examples? Possibly you could also do a step-by-step, being careful to say what screen you’re using and what you do.

When I go
to delete and recreate the database it always gives me error.

          Now I have deleted the database and created a new

one, but with each backup I get the following error.

          I am attaching the image and configuration







I guess the recreate error doesn’t even have any further description or an image, so I can’t say anything.

The backup error has an image but it has no error, unless you mean the warning (which is not an error).

For both situations, I need to see information on the error, and you might need to look in various logs like Job --> Show log --> General, About --> Show log --> Stored, About --> Show log --> Live, or in –log-file.

is the result of the last backup

Five tries of a file with the same size and hash is a sign of retries on the upload, then eventual failure. Seemingly there is a bug that lets the dlist file for the partial backup go out, then you have a big mess.

Your earlier screenshot looked more normal. The backup put dblock and dindex files, and dlist at end.

Please look further as requested in the mentioned logs. Maybe the Live log will do, but --log-file added probably has a better chance of catching sufficient details. You can start with –log-file-log-level=Retry.

When the backup completes it shows the following error: Error Size might be another retries problem.

Here, though, we have two images with different file behavior. Both have a warning. Neither says what, therefore we’re in the (unfortunately) usual spot where user has to find details to get more explanation.

Could you also perhaps offer ideas on what might be different to cause different backup failure styles? Earlier there was talk of deletes, restores, recreates, mistakes, but a step-by-step was never detailed.

Regardless, we can try working either screenshot you like, with you finding details for the red warning.

I tried to
delete the dbase and recreate the dbase, but keep giving me
these errors,

  How can I solve?

  Thank you

      Recreated database has missing blocks and 1 broken

filelists. Consider using “list-broken-files” and
“purge-broken-files” to purge broken data from the remote store and
the database.

I said before, I do not rebuild the database and if I was to
make a backup, I do not do it

are what I would consider rebuilding the database, so most recent statement below confuses me greatly.

Let me see if I can work out what steps you’re doing here, but I likely need exactly what I asked for initially.

This was said to be database delete and recreate, and a backup warning notification without warning info.

My second request for information got only this, which is roughly the same, and doesn’t give warning info, however it did give interesting hints at retries which weren’t there before. Third request for a step-by-step got only this, providing a third screenshot with a different failure from a delete and recreate. OK, work that, however this then said the past database delete and recreates were not database rebuilds. I’m totally lost.

Database management has image Do you ever run a Recreate, or do you do delete and recreate another way? How does it relate to your backup in sequence? Your last statement seemed to say you don’t rebuild then backup, yet I see talk of recreates and backups.

The latest screenshot is suggesting a delete and repair (rightmost blue button above). Are you doing that?

The documentation below might help you read logs or set up additional logging. Log information is needed:

Viewing the log files of a backup job
Viewing the Duplicati Server Logs.
Creating a new backup job, describing Advanced options such as logging on screen 5 of the backup job.

The last screenshot looks like the repair done as part of a backup didn’t succeed, but I don’t know what the prior history of the database is, because I’m hearing directly conflicting statements on recreate and rebuild.

To have a hope of solving, I also need log details from time of issue, and a better idea of what’s been done.

is where this began (delete+redo should work, but obviously can’t be done a lot), but it’s wandered all over.
Synology backups fail after upgrade to was a past issue. Are we continuing it here? Looks similar, and current topic has canary screenshots. What version is it? Canary breakage is harder, yet important…


I use synology only as ftp, everything else I do with windows7 prof. Now I use the latest beta version, but it always gives me error to re rebuild the database, it tells me that it can not rebuild and as a result it does not backup me.
We need to find a way to copy to the destination a file where it can reconstruct the whole backup tree.
This becomes convenient in case of recovery of all the files having formatted the local pc then without a local database

If your Duplicati back-up is intact at the destination, you don’t need the local DB to recover. You do need all the passwords (i.e. cloud storage account, encryption passphrase) and Dplicati itself.
In other words, you can throw away your PC, get a new one, install Duplicati on it, point Duplicati to the back-up location, provide all necessary credentials and restore files.

Restoring files if your Duplicati installation is lost gives directions for what @rumenavramov mentioned.

I’m still not getting back anything about relevant logs, so let’s see if I can instead confirm the step-by-step:

  1. Backup gives error shown here: “You may delete the local database and attempt to repair it again.”

  2. Push “Recreate (delete and repair)” button then get this: “Recreated database has missing blocks and 1 broken filelists. Consider using “list-broken-files” and“purge-broken-files” to purge broken data from the remote store and the database.”, which looks like it comes from this code after a recreate.

  3. Repeat in never-ending loop? Please confirm if this is current situation, and what about the original? From code link above, it looks like, as protection, certain recreate failures won’t delete the database.

Before I continue on this path, please confirm or correct the above, and that you did no other DB deletions.

the commands using “list-broken-files” and “purge-broken-files” how should I run them?
At this point I delete all the backups and start from scratch.
Last thing, my backup works on windows service.
The folder where it contains the configuration and a personal folder.

Recovering by purging files

The AFFECTED command might be useful if you get into manually removing files.
Using Duplicati from the Command Line offers general directions, e.g. for Windows Command Prompt.
Using the Command line tools from within the Graphical User Interface is another way (might be easier).

I’m not sure why any of the above is relevant if the plan is as below (which certainly seems easier to do).

Good. That will make sure you’re not in the case where old database stays because new recreate failed. Using Export and Import for that job can help move job’s configuration, but won’t import the old database.

I doubt it matters, except the Duplicati databases are harder to get into if running as the default SYSTEM. Typical SYSTEM path is C:\Windows\System32\config\systemprofile\AppData\Local\Duplicati

Having other folders nearby is usually not a problem, as far as I know, unless you’re altering in an update.


having reset all the database and the files resident in the nas,
I redid the new backup, result backup ok but warning

I think there might be some language difficulties, but the only way to discover the details of that warning is for you to get them, as requested. I can’t access your computer. Please read all my previous requests for your help in order to help you. Ask if you have questions. Screen shots of notifications don’t give details…

Notifies even the backup completed successfully explains how sometimes one gets the warning after the backup itself works OK. An example of a late act is sending email. In the above case, that’s what warned, however the best way to find out is from the logs. Live log will probably be fine. Please follow these steps:

  1. Open a new browser tab or window for Duplicati’s page
  2. Click About in the left column
  3. Click Show log, then click Live
  4. Set the log level to Warning using the dropdown selector
  5. Run your backup in your original Duplicati tab or window
  6. Return to the live log, and look for any warnings it logged
  7. Try clicking on warnings logged to see if they will expand
  8. Post a screenshot or cut-and-paste text copy of warning

That was the longer version of what I called About --> Show log --> Live here. It’s the easiest way to start.

Any questions about it? Thanks for your help.

It seems you’re trying to set up email, but have it only partly set up. Try adding –send-mail-from

Address of the email sender.

to see if it avoids “No sender has been specified” in the screenshot. Adjust until mail works OK.

strange nobody has changed the sending mail, I try to configure and see if it works.
thank you so much