Problem with Umlaute

MacOS Catalina, Duplicati version, Mono version
Destination is Dropbox

(“Ausflüge” is one of six Folders, two of the six are with Umlaut. With both I have the same problem. The others without Umlaut do not have this problem.)

When I ticked “Ausflüge” for backup the backup was successful.
But when I looked into the configuration again the tick has disappeared. As often as I ticked it again it disappeared every time.

In Restore “Ausflüge” is present and there seems to be nothing missing. No subfolders, no files where missing.
Also repeated backups (without tick) are successful.

The big problem now is, that I cannot de-tick “Ausflüge” for example in order to delete this folder, it is not possible. When I renamed “Ausflüge” to “Ausfluege” and ticked “Ausfluege” the backup immediately stopped with Error saying that “Ausflüge” is missing.

I don’t have a Mac but I tried reproducing your problem on Windows - it worked fine for me, I could select or deselect the folder name with the umlaut.

Maybe another Mac user can try to reproduce the issue.

copy and pasted into Linux also works fine. If this is Mac-specific, we need a Mac user. I don’t have one.

How good is anyone here on character sets and the various computer (especially macOS) encodings?

Ü Wikipedia article points out that as an 8-bit code (ISO 8859-1) this would be one byte hexadecimal FC presumably with the computer also set up to interpret the 8-bit codes that way (also known as Latin-1).

Typically, though, 8 bit-codes were a transitional thing until Unicode standardized codes for characters…
Unfortunately, I think Unicode is not directly in the filenames, but there’s further encoding as UTF-8 done, with some differences from one OS to the next. Can you test a newly typed in u-umlaut for same issue?

You can also test looking at u-umlaut in Commandline page or in some Export tests to see if it fares well.


Here’s a deeper level of Unicode subtleties that I’m talking about:

Unicode on Mac is insane. Mac OS X uses NFD while everything else uses NFC. This fixes that.
Different UTF-8 signature for same diacritics (umlauts) - 2 binary ways to write umlauts