Prevent autostart of web ui

Hello,
can I somehow prevent the web ui (http://localhost:8200/ngax/index.html) from starting automatically on every logon?
Thank you very much,
MFJ

The Web UI is closely tied to the backup engine. If you stop Duplicati from running on startup, then backups will not run. Is that what you are trying to accomplish, or are you trying to protect the web UI from being accessed by unauthorized people? If it’s the latter, you can put a passphrase on the web UI.

There is a setting inside the interface, Prevent tray icon automatic log-in, that will prevent the automatic logon when someone clicks on the tray icon, if you are using password (if the logon itself is the concern).

If you don’t want the tray icon to appear automatically after logon: are you aware that you can make Duplicati start as a service? You can learn how on the “Installing Duplicati on Windows” section of Duplicati 2 User’s Manual:

https://duplicati.readthedocs.io/en/latest/02-installation/#installing-duplicati-on-windows

During installation, you have to disable “Launch Duplicati at startup”. After that, you will need to run Duplicati.WindowsService.exe with the proper options:

https://duplicati.readthedocs.io/en/latest/07-other-command-line-utilities/#duplicatiwindowsserviceexe

By the way: I don’t know what are the implications of starting Duplicati manually (making the tray icon appear) if Duplicati is already running as a system.

P.S.: Can your problem be simply caused by the browser opening recent tabs or something like that?

P.S. 2: I just randomly found a related information: if anyone wants to run Duplicati as a service but also likes the tray icon on the same computer, just add the option “–no-hosted-server” to the path in every shortcut to the tray icon (including the shortcut on the startup folder, or any other way of making the tray icon start automatically). Something like “C:\Program Files\Duplicati 2\Duplicati.GUI.TrayIcon.exe --no-hosted-server”.