Path on server change request(windows). no \ allowed

Hello, is it possible to do a verification on the windows path on server to disallow backslash.
It gave me a headache to find out why I had on one server a fine working configuration and on a second one always currupt databases and missing files. Just because on one server I used the forward slash and on the other a backwards slash. It would be a great help if either a remark on the gui is added, or a verification is done. Unfortunatelly on checking the connection, every thing works fine, even a new folder is created, but during backup it crashes. Thanks.

Do you mean on the Destination part of your backup job? What destination type do you have selected?

If “local folder or drive” then I think it could check to make sure you’re using a path separator that matches the operating system Duplicati is running on. Other backup target types might only support the forward slash but I’m not sure.

Hello Rod,

thanks for asking.

After spending one day finding out that, as usual, the problem is on this site of the screen and how stupid I was, I was so frustrated that my report is not complete.

Sorry for that.

Here is a little more of information.


W10 ver. 1909 / 18xx on different machines.

Running duplicati as a windows service.

Gui access locally as well remote.

Backup job.

Source: local drive / folder

Destination: Webdav, ssl, web address, port 443, and this is the problem: server path.

I have used a combination of /public/vm1w10A, which works fine

and \public\vm2w10B which causes the headache.

Either with a / or \ additionally at the end.

After reconfiguring my firewall, because the non-working unit was behind the firewall, I finally found the problem.

It was not the firewall.

The odd thing is, the connection tests work. The folders are created in both ways, but checking the folders for the 3 basic files afterwards, fail.

You get error messages like: database corrupted. Any repair does not work. Or messages like three files are missing etc.

That is why I thought my firewall/nat is blocking a part of the transmission.

No, it is as simple as that: do not use . But it would be nice to have it checked or just add a comment in the gui.

It just wasn’t my day. As the service installation does not work without a clean boot, and additionally my installation path was not recognised in the registry

( due to the blanc in the path name, installation path was z:\duplicati 2… and in the registry I had z:\duplicati2… for the service), I did not pay enough

attention the my server path instruction in the backup job.

Nevertheless, today, using more and more cloud based backup, duplicati is almost a must have. In combination with archiverFs it could be nice as well.

Even though I do not like the surface of the gui and the icons whether duplicate is running or not, are to small to see, I like working with it.

Testing the database recovery functions, I could see in the windows resource monitor, that the recovery was still in progress, but the gui does not report it.

So you start have overlapping recoveries, because of missing information.

Additionally, in the manual, where it comes to the windows service installation, I would prefer an additional note, that one should be sure that the

“Duplicati.GUI.TrayIcon.exe” should not be active if running as a service, before logging on locally to http//:localhost:8200.

I had been wondering, why my schedule was not running at all. It was just the wrong instance I logged on to.

Yes, one can find out all the problems finally, but a short basic information helps.

Thanks and keep on going.

For the moment I still do some tests. If it is working in my environment I will do the donation part as well. It should be honoured.