ownCloud WebDav, NGINX, and Duplicati

I have owncloud server installed and behind NGINX. I have http forwarded to https via 301. Using windows explorer to connect to owncloud webdav works and multiple apps work without issue. I can not get Duplicati to connect over WebDav at all. No matter the settings. In my owncloud server I see it hitting with 301 redirect but nothing at all happens after that. If I uncheck use ssl in duplicati nothing every touches my server according to access.log

using domain.com/remote.php/webdav/
port 443
remote path of an existing folder
password and username is correct

Not really sure what is causing it to fail only on duplicati but works everywhere else. Any insight would be appreciated.

Put the remote.php/webdav as part of the path in stead of server. I need to do it like that for stackstorage.

I literally figured out the issue a few mins ago. Seems I was using an outdated version of mono causing SSL to freak out

So the remote.php thing resolved your issue? If so we should flag that post as the solution.

Literally said what fixed my issue. Updating mono fixed it

Ah, it was a case of SSL TLS support in Mono · duplicati/duplicati Wiki · GitHub

My apologies, I misread your initial post - thanks for clarifying for me.

I also encounter https related issues. I followed for ubuntu 16.04:

To get is working, I had to install the ca-certificates-mono packages.

Edit: I added this addition to the wiki page