Option still being used after removal

Hello, I’m using duplicati on about 100 machines and I haven’t had this probem on any other machine.
We were having a problem with the backup retention (option not supported) but it was the same as I used with all the other setups so I removed the backup, removed all duplicati files from the windows 11 pc, reinstalled duplicati and reconfigured the backup from scratch.

Now the error on this machine is again an unsupported option but this time it is with the send report module. I tried to run the command line and the error I had was:
[warning-duplicati.library.main.controller-unsupportedoption] … --nd-mail-url is not supported and will be ignored with part of the command truncated

So I ran the command again without the option (altough the syntax is correct) and it keeps giving me the same warning even when the option is not given in the command line.

I hope I have explained it clearly, if not please ask, I will try to clarify.

Thank you,



Do you use pre and post backup scripts ? If yes, can you try again without the scripts ?


Thank you. I don’t use pre or post scripts on this computer.

I’m not following well, so could use clarification, especially about how Duplicati is run here.

What about parameters-file? Or is this just a lot of options on a command line without GUI?
If you can just type into a command line, what was “reconfigured the backup from scratch”?
Or if it’s a GUI, what’s the “tried to run the command line” and the rerun without that option?


I configured the backup completely within the windows gui (installed as service).
What I meant by from scratch is I’ve deleted all duplicati files + config + temporary files and recreated the backup task within the gui.

For testing purposes, I exported the command line from the backup task and tried to launch the command from the windows cmd.
I’ve been looking over the command line and I’m beginning to think I made an error somewhere. I will have to contact the person in question to see if I can take over their computer but the Easter holidays just started here so it will probably not be for 2 weeks.



GUI job config is in Duplicati-server.sqlite, and if you mean you deleted it, it’s best to restart Duplicati.
If you mean you deleted only specific job config, then make sure Settings has no odd Default options.
Maybe even use the Edit as text to make sure it’s empty. These are also in Duplicati-server.sqlite.

This is odd output format for Command Prompt run. The tag in the square braces is what a log file has:

2023-04-11 08:19:09 -04 - [Warning-Duplicati.Library.Main.Controller-UnsupportedOption]: The supplied option --unknown is not supported and will be ignored

when I used GUI Commandline to run a compare command but gave it a bad option called --unknown.
The GUI Commandline or a Command Prompt usually produce a less lengthy version. My GUI told me

The supplied option --unknown is not supported and will be ignored
Listing changes

What parts of the command got truncated? Post says you got --nd-mail-url, so do you mean loss of se which technically isn’t truncation but is a removal? Was there something else expected but missing?

Having it warn about an option that isn’t on a Command Prompt run would be very odd, although editing lines on Windows sometimes gets a little confused. Sometimes up-arrow after error can clarify what ran.

I guess we’ll wait for 2 weeks and see if any command line oddities can be removed, but if so, the initial oddity also needs checking, e.g. at least check Settings, or maybe delete all .sqlite files from service.

would be the default location which Windows version upgrades unfortunately may move to Windows.old, meaning it’s safer to start in --portable-mode or with a custom --server-datafolder. Docs are here.

Thank you very much, I will update when possible.