OnedriveV2 not available as provider choice


#21

Before I do something I’ll regret - do you know how the container update process works? I’ve set my unRAID box to check for Docker updates Daily with a time 5 min. in the future and it’s not finding an update for Duplicati.

I could manually re-install, but I was hoping the container updater would take care of things for me…


#22

I don’t run Duplicati in a container currently, but I’d have the container configured with it’s databases mounted to either a persistent volume or just straight out to the host disk. Then just destroy the container and deploy the new image to update. The new container will upgrade the databases on startup.


#23

Agreed - that’s how is should work, but I’m trying to avoid it for two reasons.

  1. I’m still not sure I’ve got my container configured correctly so may lose all my configs (but that’s OK - I’ve exported everything just in case)
  2. I get linuxserver Duplicati container updates fairly frequently - I’ve NEVER gotten an official Duplicati container update.

I always assumed the lack of updates was because the container was the beta only, but even with 2.0.3.3 beta I didn’t get a container update. So I suspect there may be an issue with how we’re hosting or updating the container that isn’t advertising the fact. (Though again, that could just be me using containers incorrectly.)


#24

I vaguely recall LinuxServer stating somewhere they have a policy about canary releases. Maybe. My guess is they only update to the version on the website (beta 2.0.3.3) and every other release they do is just OS updates.


#25

Wow - seeing my typos quoted by somebody else is almost as bad as hearing my own voice being played back. :slight_smile:

I don’t disagree with your view of LinuxServer probably being only beta and most of the updates I see being OS related. However, that doesn’t explain why I don’t recall ever seeing an official container update.

Assuming the https://hub.docker.com/r/duplicati/duplicati/tags/ page reflects an “update” to the container, I should have seen 18 updates coming in. I just checked my update notification emails from my unRAID box and I’ve gotten 0 about the official Duplicati container.

Anyway - since no update was “detected” by unRAID I used it’s “Force update” feature to update the docker. As expected, it has reverted to version 2.0.3.3 beta of Duplicati - but I’m not sure which one as it won’t start due to a The database has version 6 but the largest supported version is 4. error. D’Oh!

So at this point I would recommend @kenkendk’s manual fix over updating the docker container if you are currently running anything NEWER than 2.0.3.3 (which I think is the last one with database version 4) understanding how to use Docker tags to make sure you’re using at least base container version 2.0.4.2. :wink:

Note that forcing the container update (resulting in 2.0.3.3. beta) then using the Duplicati updater to get to 2.0.4.2 experimental did NOT bring in the the missing Microsoft providers.


#26

What docker tag are you using?

If It’s undefined it will default to latest which may be the same as beta.

If you want canary releases you need to specify the canary tag.


#27

I’m sure I’m doing something wrong or we’d be hearing more complaints from Docker users. :slight_smile:

On my unRAID box re-installing with defaults as well as removing the container and installing from scratch did NOT bring back the missing Microsoft providers (even after using the Duplicati updater to go from 2.0.3.3 beta to 2.0.4.2 experimental). Again, this could be 100% my configuration issues so if somebody else can confirm whether or not the updated container is working for them that would be great!

I don’t know how to do that. :blush:

The “Docker Hub URL” that came in with the delete / install of the container was: https://hub.docker.com/r/duplicati/duplicati/~/dockerfile/.

On the plus side, I may have figured out how to abuse my /usr/share/Duplicati/updates container path to /appdata so it’s no longer inside the container. :slight_smile:


#28

Hmm, I’m not familiar with unRAID, but on Linux it’s just docker pull duplicati/duplicati:canary

You can definitely get away with mounting the updates folder out, but it’s a somewhat backwards way of using it :stuck_out_tongue:


#29

On the plus side, it lets me more easily test downgrades in a container… :wink:


#30

Success! (At least for me)

The issue I was having with my official Docker container on unRAID is that I’m a Docker newbie and didn’t realize I needed to set my Repository to “duplicati/duplicati:experimental”.

Using the default of “duplicati/duplicati” just pulled the most recent stable version (hence 2.0.3.3 beta). Even though I updated Duplicati to 2.0.4.2, the Docker OS was still based on the 2.0.3.3 image so it did NOT include the missing DLLs.

When I changed my Repositor to “duplicati/duplicati:experimental” it updated my Docker container (without losing anything) and now that it’s based on the 2.0.4.2 container it DOES show the OneDrive v2 options!

So basically, everything I said above on this thread can be ignored because I was using the Docker images incorrectly.


As for @ts678’s issue, it sounds like he had been doing things the RIGHT way (using the :linux-amd64-2.0.4.1_experimental_2018-11-08 tag) and still ran into missing OneDrive v2 destinations.

My guess is that this might have been be due to the 2.0.4.1 container OS still missing the dlls and if he had used 'duplicati/dupliacti:experimental` OR updated his docker container without the manual fix then it would haev worked for him.

But hey - I got to learn something new and he verified kenkend’s manual fix works. :slight_smile:

If @ts678 agrees with this then I think we should flag kenkendk’s 2.0.4.2 release post as the Solution (unless @discrucio, @psywolf85, or @arktex54 can confirm it did NOT work for them).


#31

I started using Docker two days ago, so I didn’t know about automatic updates or notifications. I did see that getting a specific image needed a tag. That worked well for the “duplicati” images. Still haven’t found how to achieve the same thing for “linuxserver” in terms of knowing what Duplicati version a given tag will provide…

Can you provide any good links on the Docker update scheme? I’m finding ones that sound like an “update” means wiping out the application data the old one had (and the reply to that is often “don’t store app data”). Basically, an update sounds like a fresh install, although I do see some tools attempting to help the problem.

My post on 2.0.4.1 failing was 9 hours before 2.0.4.2 existed (thanks to @kenkendk for the amazing work), so yes it was missing dlls. I gave comment on updating earlier. But what of @JonMikelV Windows 10 issue, and it’s also not clear whether the opening post from @arktex54 was Windows, Docker, or something else. While I’m thrilled about the Docker fix, it’d be good to know that Windows is working (though it works for me).


#32

Linuxserver are not super transparent about the images. They do increments every time they update anything in the image (e.g. OS packages). I downloaded the image and manually checked the version of the commandline tool. It’s 2.0.3.3. It usually works well since they just get the latest stable software. Sadly we don’t have stable software yet :smile:

In essence when updating docker you just throw away your container and make a new one. What’s important is to “persist” the data that matters between containers. In our case you want to persist your Duplicati database.

Persistence can be done with docker volumes. I like to go a slightly different way using bind mounts. I find them more tangible because they exist outside the container so you can see and interact with it.


#33

I’m guessing my Windows 10 issue goes back to the “base” vs. “current” version design.

When I ran BackendTool.exe help it was in the INSTALL for, not the update folder. I think there’s a pre-existing issue with those tools not looking in updates folder for a newer version.

I’ll try to test that later tonight.

As for Docker stuff, I’m strictly a consumer so far. The container updates DO fully replace the existing container which is why it’s so important to get your container mappings correct.

Basically, there are certain paths (such as /backups, /data, and /source) that Duplicati will look to use. By default, those paths are INTERNAL to the container so anything written there will be lost during a container update.

But you can map those internal paths to EXTERNAL footers l folders on the device running the container. That way stuff saved to those files is store outside the container won’t be lost during a container update.


Edit: looks like Pectojin beat me to the punch. I agree on mount points / mapping vs volumes.


#34

2.0.3.12 base started 2.0.3.14, and the code isn’t recently added. Process Monitor showed it like this:

6:02:23.1838051 PM duplicati.commandline.backendtool.exe 8144 Process Start SUCCESS Parent PID: 8972, Command line: "C:\ProgramData\Duplicati\updates\2.0.3.14\duplicati.commandline.backendtool" help, Current directory: C:\Program Files\Duplicati 2\,

Regardless, I hope there’s a nicer explanation for your result than there being another bug to find. :slightly_frowning_face:

Back to Docker, it sounds like my test of just using a new container should be equivalent to an update regarding whether or not backends are found, and I probably won’t set up any more realistic test now, however I’d welcome test reports from anyone who’s already set up in a way that allows upgrades, i.e.:

Ditto. :wink: I’m also looking for testers of manual fix or new image at GitHub # 3198 I updated about this.


#35

Confirm that the issue is fixed with the latest experimental image (linux-amd64-2.0.4.2_experimental_2018-11-12). Logs:

* ServerVersionName : - 2.0.4.2_experimental_2018-11-12
* ServerVersionType : Experimental
* StartedBy : Server
* BaseVersionName : 2.0.4.2_experimental_2018-11-12
<truncated>
* OSType : Linux
<truncated>
* backendgroups : {"std":{"ftp":null,"ssh":null,"webdav":null,"openstack":"OpenStack Object Storage / Swift","s3":"S3 Compatible","aftp":"FTP (Alternative)"},"local":{"file":null},"prop":{"s3":null,"azure":null,"googledrive":null,"onedrive":null,"onedrivev2":null,"sharepoint":null,"msgroup":null,"cloudfiles":null,"gcs":null,"openstack":null,"hubic":null,"amzcd":null,"b2":null,"mega":null,"box":null,"od4b":null,"mssp":null,"dropbox":null,"sia":null,"jottacloud":null,"rclone":null}}
* GroupTypes : ["Local storage","Standard protocols","Proprietary","Others"]
* Backend modules:aftp amzcd azure b2 box cloudfiles dropbox ftp file googledrive gcs hubic jottacloud mega msgroup onedrive **onedrivev2** sharepoint openstack rclone s3 ssh od4b mssp sia tahoe webdav
* Compression modules:zip 7z
* Encryption modules:aes gpg

#36

D’Oh! I completely forgot backends are listed on the About -> System Info page! :slight_smile: