Newbie- Cannot get any of my backups working from OSX to B2

Running High Sierra. I signed up for B2. Made some private buckets. Installed Duplicati on multiple home machines. Connection testing is fine.

To test on my own machine first, I selected my photos folder. I did a “run now” and this is what I get:

Found 2041 files that are missing from the remote storage, please run repair

I went to B2 and there is nothing there.

I tried it on other mac machines in my house. Again, connection is fine. Nothing is uploading.

I’m not sure what I’m supposed to do next. I’ve tried repairing and purging. Nothing changes. Help.

Hi @egizzi, welcome to the forum!

When you did the “run now” on your own machine was that the first time that the backup had run? I’m asking because the “found n files that are missing from the remote storage” error happens when the local Duplicati database of what’s already been backed up has files listed that Duplicati can’t find at the Destination.

This could happen if for an number of different reasons (which may not actually be what happened to you) that include:

  • a backup ran with bucket A as your destination then you changed the destination to bucket B and ran the backup again
  • a backup ran with a bucket A destination then outside of Duplicati all the files in bucket A got deleted
  • a backup run then the database was copied to (or pointed at) by another backup
  • the files are actually there but when Duplicati queries the destination for the file list the destination (in this case B2) responds that there are no files
  • multiple backups were pointing to the same destination bucket, both were run, then one was deleted including destination folders (this scenario is only an issue with older versions of Duplicati)

So the first question is what version of Duplicati are you using and the second question is can you log into B2 through their UI and confirm whether or not there are actually files there.

If there are no files then either they were deleted or Duplicati is backing up to a different destination than you think. If there ARE files then there may be a communication or authorization problem with your destination.

You could try creating a small test backup (a single file is adequate) to another (or existing) bucket and then see if file(s) show up at the destination.