New backup dates showing

Is that screenshot edited? The blue bar with the check mark on the left looks like it was dropped on top.
You can see a shadow effect, and it’s obscuring half of the dropdown activation box on the far right end.
What happens if you click the little bit of the downward arrow box that you can see there, or do search?

I can promise you it’s not edited and even video it if you want. I think it’s the way my mac shows it.
The downward arror just shows the same result (empty box) and doing a search shows Failed to connect: Unparsed data: undefined

I did a Google image search, but couldn’t find it. I wonder what check means, and if all clears if it works?
I guess we’ll find out if we get there, or a Mac user helps. Have you restored before without the problem?

For me, it’s a two-step message. It says Getting file versions, then Fetching path information, though it doesn’t show even the Restore files title until after that. Watching About → Show log → Live → Profiling might be useful to see if it’s gotten stuck. Log newest is at top. After my tree appears, I have this:

Another thing to try is to see if it gets versions OK, even though I guess yours got past there to Fetching
The FIND command can be run from Commandline by changing screen settings (which may be backup). With blank Commandline arguments box data, it lists versions (so you can see if it can do that right now).
With a * in that box it should list files. Again, goal is to see if something easier and seemingly similar runs.

If somehow this works, then you could perhaps even try a simple (for ease) restore on this screen, which could be used to tell if it looks like a pure restore problem, or maybe something odd in the web interface…

I wonder if it’s possibly a javascript/client side browser display issue. Not sure what browser you are using, but can you try a hard refresh? Chrome on Mac: hold shift and click Reload. Safari on Mac: hold option key and press E.

It goes “getting file versions”, shows nothing in the logs. I’ll try the find command

I’m on chrome, I tried a hard refresh and same issue.

@the1 what’s the relationship between this and your Duplicati Failed to connect proxy error?

That one used two machines, some reverse proxies, direct restore, restore from configuration.
All of that is opposite from this issue, opened the same day. The other one did, though, show a
blue box of typical style for a Duplicati connection error, and the box discussed in current issue.
The color of blue is different, which answers my question of whether it was a bad Duplicati box.

Earlier it got to the “fetching” message below. And now? Or did the “fetching” comment mean “getting”?

You have live log all set up at Profiling level, open up backup job menu on center (not left) of home page, click Restore files under Operations section, and see nothing in live log? Seems extremely strange.

Does your Chrome have F12 key developer tools so you can see if you’re sending anything to Duplicati?
Mine runs like below. You should have all requests and responses (e.g. Status 200) except for long polls.

I tried to restore on another machine with my configuration and I got that.
It meant getting.
It shows nothing (live logs and profiling
It shows I am sending something to duplicati

So current one is macOS going to Duplicati on same system. Other is macOS trying different restore similar to what one might do for disaster recovery. That one would have its own install of Duplicati, but wouldn’t have a permanent database, so for Direct restore from backup files would first gather destination access data on first two screens. You press Connect and then the third screen is what the initial screen looks like here – dropdown for versions isn’t filling in. Strange that it does that two places.

How does the proxy fit in? Is that a reverse proxy on some remote destination that both systems used?
What storage type is the destination configured in Duplicati? You should be able to see remote access when Duplicati accesses the remote, and can see historical ones in <job> → Show log → Remote on current system (which is a Duplicati with a database – this might not work on the other system tested).

This is strange. Even at Information level, mine does some list requests to the backup destination.
Is your Duplicati idle at the moment? You can see About → System info to verify there’s no activeTask:


So (ignoring polls), what is it sending, what status is it getting, and how far along the sequence does it go?

My versions are in the filesets response. You can click on Headers and Response to see the interaction.

My mac uses macos, all machines use ubuntu. The one this thread is about uses apache2, it’s all backed up over SFTP.

I think I need a more extensive text (or diagram, but that might be hard to do) on what’s where.

This is now sounding like Duplicati is on Ubuntu, backing up to SFTP somewhere on network.
Ubuntu uses apache2 reverse proxy to allow access from Chrome running on mac. Is that it?
It fits with the “all machines” comment. You admin mamy Duplicati from Chrome on the mac?

Are there other Ubuntu machines running Duplicati in a similar config? Do they restore better?
If not, can you try a restore in local browser on Ubuntu that displays back to you as an Xclient?
Port forwarding from mac to Ubuntu might also bypass the proxy, if you know how to do that…

The reason I’m trying to bypass any reverse proxy is that certain configurations break restores.
The reported failure mode doesn’t match yours, but I’d like to see if issue seems proxy related.
I don’t run any proxies, so can’t help with setup, but if it works without proxy, that’s a big clue…

To expand on that (if there’s a proxy here), go to Issues and filter with is:issue restore proxy

Ok,just in case this isn’t fixed. The data loss was last thursday and i have it configured to delete backups after 7 days. Is there a way I can make it so the backup wont delete as i need it

Basically, the machine is running duplicati with apache2. backing up to SFTP to another server. I’m running chrome on my mac and using this to control duplicati.

i have another machine running nginx that works but this machine was with nginx but didnt work either when I tried this so I tried apache2

Just change your retention settings on page 5 of the backup job config. Set it to “keep all backups” and click the Save button.

By the way - you are using a reverse proxy on the Duplicati machine just so you can access the web UI from somewhere else on the LAN? There’s a much simpler way to accomplish that. Just turn on the “Allow remote access” option in main Settings and restart Duplicati. No need for a remote proxy.

You almost certainly should use a password for the UI in this case, unless you completely trust the LAN environment. Also, don’t expose the Duplicati web UI directly to the internet.

What does allowing remote access do? What do I do for the hostname? I’ve already got a password. Do you reckon doing this could fix the issue

Per Issue search I posted above (feel free to look at others there), maybe these could help:

Proxying behind Apache 2.4 breaks restore file browser #2531

You can fix this easily by adding the AllowEncodedSlashes On option to the virtual host

Unable to restore under Linux (reverse proxy issue) #3097

I was able to fix it by adding the following to my Apache proxy configuration:

    AllowEncodedSlashes On

By default Duplicati only binds to the localhost IP address, so it’s not accessible from another computer. Setting the “remote access” option causes it to bind to all network interfaces. If you do that you can access Duplicati by going to http://remote-machine-lan-ip:8200 - no need for a reverse proxy at all.

Settings in Duplicati covers password, remote access, and hostnames (the one for this server) setup.

I did this and tried to restore, it goes to listing backup dates before failing to connect