Need case insentivite folder filters but nothing is working at all

I’d like to have some case insensitive filters so I can do things like catch “cache” and “Cache”. However, nothing is working even if the case matches, and I’m really confused why, since even the inbuilt way doesn’t do anything.

This is what I’ve tried so far:

[exclude folder] cache
[exclude expression] cache\\*
[exclude regex] .*/(?i)cache$/.*
[exclude regex] .*/cache/.*
[exclude regex] .*\\cache
[exclude regex] .*\\cache\\
[exclude regex] .*\\cache\\.*
[exclude regex] .*cache.*

This worked for me:


In my testing the (?i) isn’t needed on Windows, but maybe it is on non-Windows platforms.

On the filters area, click the 3 dots and “Edit as Text” and just add the line exactly as shown above. I prefer to use this method because there are still problems with the UI when its set to “Edit as List” - it can foul up the filters a bit.

Thanks for checking it out, it looked like one of my previous tests was causing some issue as your example only worked after I removed some of the old lines. Everything appears to be fine now anyway, cheers.

I read (?i) is only needed on Linux, but for the sake of completeness I’d prefer to manually specify it instead of just assume it :slight_smile:

1 Like