Missing AlphaVSS.x64.dll error on clean install

I have error in clean install:

The file or assembly “AlphaVSS.x64.dll” or one of their dependencies could not be loaded. The specified module could not be found.

After press OK I have no error. But this message appear always when I edit job.

Does AlphaVSS.x64.dll actually exist on your system? It should be located in the subfolder alphavss, under the Duplicati program folder.
The alphavss folder should contain 3 files: AlphaVSS.Common.dll, AlphaVSS.x64.dll and AlphaVSS.x86.dll.

It looks like something went wrong when copying the files of the last update to the Duplicati program folder. My suggestion:

  • Download the latest Zip version of Duplicati.
  • Stop all Duplicati instances (Duplicati.Server.exe, Duplicati.GUI.TrayIcon.exe, Stop Duplicati Windows service).
  • Check in Task Manager if there are no running processes starting with Duplicati. If there are any, end these processes.
  • Extract the contents and copy it over the current files in the Duplicati program folder. All files an be overwritten, you will not lose any data or settings.

Unfortunately, after these actions I see same error.

The alphavss folder should contain 3 files: AlphaVSS.Common.dll, AlphaVSS.x64.dll and AlphaVSS.x86.dll. - Yes and root folder of D2 contain: AlphaVSS.Common.dll

AlphaVSS needs the Visual C++ 2017 Redist package. You could try to (re)install this package from here:

Scroll down to the bottom of the list. There you’ll find Microsoft Visual C++ Redistributable for Visual Studio 2017. Download it for the same processor architecture as your Duplicati install (x86 or x64, or both).

4 Likes

Thank you! All OK. I think better to add this to setup or error message with message to download “Visual C++ 2017 Redist package”.

Glad to hear it’s working now.
I’ve marked my own post as Solution if you don’t mind, to help others who run into the same issue.

It sounds like you have a situation where the installer is omitting install of some files (I think you have it resolved, but I would like to know why it happens).

Can you look in your antivirus logs or quarantine folders and see if the files are retained here?

All - I moved this to it’s own topic for now so the Should 2.0.2.19 be promoted to the experimental channel? topic doesn’t get too diluted.

Oddly, the “solved” icon is still showing on the old topic. If it doesn’t clear itself out in a bit I my un-solve then re-solve this topic just to see what happens.

I had the same problem. I installed the 2015 and 2017 versions of the C++ files, rebooted, and the problem went away.

The FAQ on this website says that the 2015 version is needed, but some places, like this thread, say that the 2017 version is needed. Maybe the FAQ needs an update?

May I suggest adding all those necessary files to the Windows installer so that they are installed automatically with Duplicati? Also, it would be great to add this info to the error message and the VSS advanced option help text so that users can see the solution there instead of having to search forum threads about the error message. Thanks!

2 Likes

So a week or so ago I pulled the trigger and installed Duplicati 2.0.2.19_canary on a client’s machine. It’s running fine OTHER than the following message (I’m using --snapshot-policy=On):
Failed to create a snapshot: System.IO.FileNotFoundException: Could not load file or assembly 'AlphaVSS.x64.dll' or one of its dependencies. The specified module could not be found.

I checked C:\Program Files\Duplicati 2\alphavss and all 3 files mentioned are in it.

So it appears in my case (fresh install of 2.0.2.19 and no updates yet) the files ARE installed but possibly not registered?

Before I do something crazy like update to 2.0.2.20 (yay!) is there some testing I could do to help figure from out where the issue with this coming?

Did you install the VC++ 2017 Redist package? If not, see solution a few posts above.

I did not, and will certainly do so once any testing is done. (I’m not in any hurry.)

What I’m trying to figure out is why the files DO exist in the alphavss folder but Duplicati says they can’t be found.

For now I’m assuming it has something to do with a failure to register the DLLs on installation and that all installing the Redist package really does for Duplicati is to provide a registration of the files.

I used to know how to check what was registered and do manual DLL registrations, but it’s been so long I’ll have to look it up somewhere. :slight_smile:

According to Settings -> Apps & Features installed VC++ 2017 Redist (x64) on 05/19/2018 and am still getting the warning.

I do NOT have installed VC++ 2015 which seems to have worked for some people, should I give that a try or are there other things worth testing first?

Manual solution of the problem.

Open the *.csproj file with your own notepad

 <PropertyGroup Condition="...">

         ...Other Props...

         <!-- Just add the following line here -->
         <Prefer32Bit>false</Prefer32Bit>    

 </PropertyGroup>