# Minio S3 Object Name Errors

**URL:** https://forum.duplicati.com/t/minio-s3-object-name-errors/4987
**Category:** Support
**Created:** [October 18, 2018, 4:34am UTC](https://forum.duplicati.com/t/minio-s3-object-name-errors/4987 "2018-10-18T04:34:19Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![DarkKnight](https://forum.duplicati.com/user_avatar/forum.duplicati.com/darkknight/32/2184_2.png) [@DarkKnight](https://forum.duplicati.com/u/DarkKnight)
#### Post date: [October 18, 2018, 4:34am UTC](https://forum.duplicati.com/t/minio-s3-object-name-errors/4987/1 "2018-10-18T04:34:20Z")

</div>

Using Duplicati - 2.0.3.3\_beta\_2018-04-02 & Minio RELEASE.2018-10-06T00-15-16Z on different machines on the same LAN.

When using Duplicati to backup to my Minio backend, Duplicati errors out with “Object name contains unsupported characters.” message at the bottom. Nothing shows up in the minio log.

A github search reveals that this might be related to how Minio stores objects in the filesystem, and that it’s ‘working as intended’, which means that some incompatibility exists due to use of ‘//’: [Object name contains unsupported characters when using double forward slash (//) · Issue #5874 · minio/minio · GitHub](https://github.com/minio/minio/issues/5874)

At the same time, I see multiple threads on here that suggest Duplicati+Minio is working fine.

> [@Connecting to Minio via custom URL](https://forum.duplicati.com/t/connecting-to-minio-via-custom-url/245/11):
>
> I appreciate the reply. I actually tried by IP address as you can see in my command line–I do not have internal DNS set up on my home network. I’m using the exact same version this time, but I didn’t allow Duplicati to add a username to the bucket. And this time, Duplicati was able to connect and back up a test directory. However, it seems that the command line exporter works inconsistently. As you see above, in my original post, it URL encoded the colon before the port number as “%3A” in the …

> [@Duplicati with Minio replacing crashplan friends](https://forum.duplicati.com/t/duplicati-with-minio-replacing-crashplan-friends/1528):
>
> Hello all, I’m currently testing a possible migration option using a Duplicati/Minio setup. Later this year Crashplan will stop with its Home (green) version. Currently I use the friends option for years. I use this for my own data to store at my brother’s Nas and I have also 5 paying clients which store data at my NAS. So far my results are fairly positive. I’ve setup Minio as a lightweight S3 compatible object storage target running in a docker on a Synology NAS. Duplicati is connecting the…

This last one specifically says Minio is a supported destination though I don’t see it in the list, and ‘S3 compatible’ often reverts to ‘Amazon S3’ when I try to edit the settings if that makes any difference.

What am I doing wrong that it’s not working?

---

<div class="post-metadata">

### Author: ![DarkKnight](https://forum.duplicati.com/user_avatar/forum.duplicati.com/darkknight/32/2184_2.png) [@DarkKnight](https://forum.duplicati.com/u/DarkKnight)
#### Post date: [October 18, 2018, 4:38am UTC](https://forum.duplicati.com/t/minio-s3-object-name-errors/4987/2 "2018-10-18T04:38:12Z")

</div>

Literally right after posting this I found:

> [@400 - bad\_request: File names must not contain '\\'](https://forum.duplicati.com/t/400-bad-request-file-names-must-not-contain/3523/5):
>
> Can you (and @dunnry) let us know what version of Duplicati you’re running and on what OS (Linux, MacOS, Windows)? Oh, and are you able to use the job menu to Export your job “As commandline” and paste it here (with personal stuff like passwords & email address removed)?

The problem is the pre-populated destination contains /source/

Remove the destination and it works as intended. Leaving this up for others to find.

---

<div class="post-metadata">

### Author: ![JonMikelV](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/439d5e/32.png) [@JonMikelV](https://forum.duplicati.com/u/JonMikelV)
#### Post date: [October 18, 2018, 12:48pm UTC](https://forum.duplicati.com/t/minio-s3-object-name-errors/4987/3 "2018-10-18T12:48:36Z")

</div>

Thanks for pointing this out! I flagged your post as the solution. 🙂

I don’t use Minio myself so want to double check - they issue happens if there are ANY slashes in the Destination field, right?

If so, it might be with a UI tweak to validate that field…

---

<div class="post-metadata">

### Author: ![DarkKnight](https://forum.duplicati.com/user_avatar/forum.duplicati.com/darkknight/32/2184_2.png) [@DarkKnight](https://forum.duplicati.com/u/DarkKnight)
#### Post date: [October 18, 2018, 4:33pm UTC](https://forum.duplicati.com/t/minio-s3-object-name-errors/4987/4 "2018-10-18T16:33:01Z")

</div>

I tested it, and /source/ (default) does not work; /source does work but doesn’t actually create a /source folder in the bucket. All the files are dumped straight into the bucket root, which is entirely functional, but cumbersome if you wanted to backup several machines without creating unique buckets for each one.

If you want to test it out yourself, I can PM you with credentials and give you access to a bucket.

This might be relevant for better implementing support for Minio. It describes differences in the API vs S3:

[https://docs.minio.io/docs/minio-server-limits-per-tenant.html](https://docs.minio.io/docs/minio-server-limits-per-tenant.html)

---

<div class="post-metadata">

### Author: ![JonMikelV](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/439d5e/32.png) [@JonMikelV](https://forum.duplicati.com/u/JonMikelV)
#### Post date: [October 18, 2018, 9:50pm UTC](https://forum.duplicati.com/t/minio-s3-object-name-errors/4987/5 "2018-10-18T21:50:26Z")

</div>

Thanks for the info & bucket offer.

I actually have a Minio Docker container running but never got around to configure using it for anything. 🙂

Maybe now is a good time for me to get back to that…

---

<div class="post-metadata">

### Author: ![DarkKnight](https://forum.duplicati.com/user_avatar/forum.duplicati.com/darkknight/32/2184_2.png) [@DarkKnight](https://forum.duplicati.com/u/DarkKnight)
#### Post date: [October 19, 2018, 12:55am UTC](https://forum.duplicati.com/t/minio-s3-object-name-errors/4987/6 "2018-10-19T00:55:24Z")

</div>

While I’m here, I should mention that I updated [duplicati fails to connect to backblaze b2 · Issue #3333 · duplicati/duplicati · GitHub](https://github.com/duplicati/duplicati/issues/3333) to reflect that B2 selection screen needs a UI tweak as well. The suggested required information is incorrect with regards to what B2 actually expects to see to auth properly.
